• Type bool can not be solved in 5748g

    The program I used is the example project with the name of hsm_freertos_mpc5748g. When I try to debug the project, the type bool can not be resolved. I used to method which is mentioned in the https://community.n...
    Jupeng Zhao
    last modified by Jupeng Zhao
  • Issue with S32K144 CAN Bootloader

    Dear friends,   I have completed CAN Bootloader program recently. I am able to flash my application program through my bootloader and the program is working as expected. But if i change my application program by...
    Mansoor Basheer
    last modified by Mansoor Basheer
  • can't program S32 bootLoader example for mpc5748G

    Hi   this topic has many info in the web yet  nothing help me to overcome this issue. I'm using the DEV-KIT of mpc5748G chip and working on the bootLoader example, My first basic thing to do is to load thi...
    dany amsalem
    last modified by dany amsalem
  • Attach to running target keeps resetting mcu

    Hi,  I need to connect to a running target for debugging purposes (s32K11x mcu).  The debugger resets the MCU event if I select "Connect to running target".  Hovering with the mouse over the checkbox...
    Catosh
    last modified by Catosh
  • Corrupted metadata and hardfaults

    Hi all;  I noticed a fancy behavior using S32ds and segger jlink.  I have a fully working project, sometimes I need to make some edits and reload the project.  Out of the blue, I get an hard fault on ...
    Catosh
    last modified by Catosh
  • Unable to start debug session on MPC5748G board. download stops at 98%

    Hello, I am using the MPC5748G board and I am facing an issue while debugging the code. I have compiled the linflex example provided on the website and earlier it was running fine. Currentlywhile starting a debug ses...
    veeresh ambe
    last modified by veeresh ambe
  • How to make GHS as the compiler in S32 DS, Does S32 DS support  to debug code programming with  Autosar OS and BSW?

    Hi, Does S32 DS suppport GHS compiler? how to setting? I have one project that compiled by GHS compiler, the project has AUTOSAR OS + BSW,  Can i move this project to S32 studio, and specify the GHS for comiler...
    jianmin zhou
    last modified by jianmin zhou
  • Execution of OneRF_4Antennas_demo_s32r274 example project

    Hi,   We are trying to run the OneRF_4Antennas_demo_s32r274 example project (available with S32_RSDK_S32R274_372_RTM_1.2.0 update) with TEF810B RADAR front end.   We are using 1st configuration o...
    Sushant Susheel Gosavi
    last modified by Sushant Susheel Gosavi
  • ERROR: InitTarget(): PCode returned with error code -1

    I am working with my own boards(S32K144). J-link can't connect the board :   Connecting to target...ERROR: InitTarget(): PCode returned with error code -1 ERROR: Could not connect to target. Target connection ...
    jamesyim
    last modified by jamesyim
  • Questions about CAN RX signal reception failure

    hello   I used CANoe to transmit the CAN signal to the EVB board. However, CAN signal was not received in EVB. The example code I used is can_pal_s32k144 of 'S32K1xx RTM SDK v3.0.0 Example Project' And the sampl...
    JAE MIN SHIN
    last modified by JAE MIN SHIN
  • MII on MPC5748G

    Hi, I have a custom board made from the devkit MPC5748G. Instead of RMII, we use MII and its directly connected to another chip that uses RvMII.   Is there already some sample code available so that I can use t...
    Tiju Jacob
    last modified by Tiju Jacob
  • how to use printf using lpuart in s32k118

    Hello. I want to use printf using lpuart0 or lpuart1 in my s32k118 board(now I use IAR Compiler.)   Could you please let me know how to use printf using lpuart.   I already below example. but it is for s32...
    MinYeop Na
    last modified by MinYeop Na
  • Splitting processing across multiple cores

    Hi, I am working with the dual core MPC57xx processor and use NXP's S32DS IDE. Initially for proof of concept, I designed the entire application from start to end to be executed on one processor core. Fairly simple -...
    Jyothsna Rajan
    last modified by Jyothsna Rajan
  • Flash does not working

    Hi,   I use S32DS and S32K144.   When I test the flash write, I wrote the test data at adress 0x00. After that, I can't flash program. How to resolve it?  
    Byungju Kim
    last modified by Byungju Kim
  • How to create OpenSDA for s32k

    Hello I want to use OpenSDK v2 ( CMSIS-DAP ) at S32K. But CMSIS-DAP isn't support S32K. So I tried porting CMSIS-DAP at S32K.   But.... I can't find information for porting at S32K Datasheet. Programming Pag...
    Suchang Ko
    last modified by Suchang Ko
  • Program "-E" not found in PATH

    I uninstalled and then installed a newer version of S32DS, and I am not able to debug the project.   I also have this message: Orphaned configuration. No base extension cfg exists for com.freescale.s32ds.cross....
    mfarag
    last modified by mfarag
  • when i debug the code ,.elf file is generating,i am not able to upload that file to the board(S32V234evb),I am not getting the authentication mesage.

    shivaraj moger
    last modified by shivaraj moger
  • S32DS Debugging without hardware

    Hello, I have just installed S32DS IDE to develop code for the DEVKIT-MPC5748G, using example "MPC5748G-FlexCAN_with_interrupts-S32DS_Z4_1" I want to simulate the code, without hardware connected. Is this possible ...
    Colin McDonough
    last modified by Colin McDonough
  • Debug always loads twice

    Hello When I do a debug build, the download ALWAYS FAILS the first time, then it has to redo the download which ALWAYS works the second time. (please see attached) What am I doing wrong ? S32DS on DEVKIT-MPC5748G&#...
    Colin McDonough
    last modified by Colin McDonough
  • Re-Flash issue with S32 Flash tool for S32V234

    Hello, I'm trying to flash u-boot into eMMC and I got the issue that fail to load algorithm and device file when I reprogramming it. There was no issue to flash u-boot at the first time, however, the issue was occur...
    John Yoo
    created by John Yoo