• Need Help with S32 Design Studio - Looking for a programmer

    Hello, I am new to S32 design studio, i am looking for a consultant / programmer to help with the project i am working on.   Thanks   Eitan Shmueli
    Eitan Shmueli
    last modified by Eitan Shmueli
  • FreeMASTER

    How is it that ZLG's usbcan-ii device no found keeps appearing in the FreeMASTER
    磊 任
    last modified by 磊 任
  • Bug Issue in S32 for S32K144_PT2000_EXAMPLE

    Hello, I am new to S32 and to NXP community and I am working with FRDMPKPT2000EVM Evaluation Board (EVB), I am trying to load and debug a sample file "S32K144_PT2000_EXAMPLE" with an error.   Can anyone hel...
    Eitan Shmueli
    last modified by Eitan Shmueli
  • MPC5748G bootloader to application jump issue

    I am developing serial Bootloader for MPC57485G. flow of the the process is simple ,after every power on controller goes to bootloader code waits for 1sec to receive an file over serial uart. If the new file is receiv...
    prasad choramale
    last modified by prasad choramale
  • A Problem about autosar

    I am currently researching AUTOSAR development, I  found that the NXP provided MCAL files for MPC5744P and  I want to konw if I can use S32DS to compile the example project which provided by NXP.
    zhao hanxin
    last modified by zhao hanxin
  • S32K146 Single Step not stepping correctly

    Can anybody advise as to why Single Step functions step-into and step-over both perform the same step-into function. Am I missing some setting somewhere?
    Allan Crook
    last modified by Allan Crook
  • How to flash motorola srec binary file to S32K144 with S32 Design Studio?

    Hi,   I develop with S32K144 EVB. Regardless of project, I would like to flash motorola srec binary file to S32K144 EVB. How to flash the binary file to S32K144, using S32 Design Studio?
    Byungju Kim
    last modified by Byungju Kim
  • How to solve below issues in S32 design studio PA V1.2

    Hi, I am using S32ds for power architecture V1.2  for MPC5777c controller.   1.During running i am unable to see the expressions. By halting only(suspend) i can able to. Is this version has that feature? ...
    maddula rajesh
    last modified by maddula rajesh
  • S32 Design Studio and Keil Ulink2 support

    Hi everyone, Is it possible to use Keil ULINK2 as programmer/debugger for S32 Design Studio (S32K144)?  If not is it something we consider or this must be considered by Keil?   Thanks and BR Stefano
    Stefano Gattazzo
    last modified by Stefano Gattazzo
  • Debugging S32K148 with iC5000

    Hello, I'm trying to build an application in S32 Design Studio and debug it with iC5000. I'm using S32K148 evaluation board, so I created new project and selected S32K148 in EmbSys. The iC5000 refuses ...
    Michael Pan
    last modified by Michael Pan
  • Is there a script available which flashes one or multiple .elf files in the MPC5748G without using the S32 design studio IDE?

    I've been using the S32 design studio IDE for implementing/debugging/flashing the MPC5748G and I'm wondering if there is a script available which flashes one or multiple .elf files in the MPC5748G without us...
    F Merkus
    last modified by F Merkus
  • lpuart_echo_s32k144 example not work

    I have a S32K144 EVB. I tried to run "lpuart_echo_s32k144" example but in terminal I can't write message. I tried to run second example "uart_pal_echo_s32k142" and the result is the same   "LPUART_s32k144" examp...
    Tom Tame
    last modified by Tom Tame
  • Type bool can not be solved in 5748g

    The program I used is the example project with the name of hsm_freertos_mpc5748g. When I try to debug the project, the type bool can not be resolved. I used to method which is mentioned in the https://community.n...
    Jupeng Zhao
    last modified by Jupeng Zhao
  • Issue with S32K144 CAN Bootloader

    Dear friends,   I have completed CAN Bootloader program recently. I am able to flash my application program through my bootloader and the program is working as expected. But if i change my application program by...
    Mansoor Basheer
    last modified by Mansoor Basheer
  • can't program S32 bootLoader example for mpc5748G

    Hi   this topic has many info in the web yet  nothing help me to overcome this issue. I'm using the DEV-KIT of mpc5748G chip and working on the bootLoader example, My first basic thing to do is to load thi...
    dany amsalem
    last modified by dany amsalem
  • Attach to running target keeps resetting mcu

    Hi,  I need to connect to a running target for debugging purposes (s32K11x mcu).  The debugger resets the MCU event if I select "Connect to running target".  Hovering with the mouse over the checkbox...
    last modified by Catosh
  • Corrupted metadata and hardfaults

    Hi all;  I noticed a fancy behavior using S32ds and segger jlink.  I have a fully working project, sometimes I need to make some edits and reload the project.  Out of the blue, I get an hard fault on ...
    last modified by Catosh
  • Unable to start debug session on MPC5748G board. download stops at 98%

    Hello, I am using the MPC5748G board and I am facing an issue while debugging the code. I have compiled the linflex example provided on the website and earlier it was running fine. Currentlywhile starting a debug ses...
    veeresh ambe
    last modified by veeresh ambe
  • How to make GHS as the compiler in S32 DS, Does S32 DS support  to debug code programming with  Autosar OS and BSW?

    Hi, Does S32 DS suppport GHS compiler? how to setting? I have one project that compiled by GHS compiler, the project has AUTOSAR OS + BSW,  Can i move this project to S32 studio, and specify the GHS for comiler...
    jianmin zhou
    last modified by jianmin zhou
  • Execution of OneRF_4Antennas_demo_s32r274 example project

    Hi,   We are trying to run the OneRF_4Antennas_demo_s32r274 example project (available with S32_RSDK_S32R274_372_RTM_1.2.0 update) with TEF810B RADAR front end.   We are using 1st configuration o...
    Sushant Susheel Gosavi
    last modified by Sushant Susheel Gosavi