• LWIP Stack porting on top of SafeRTOS 

    Hi Team,   I am using S32 design studio for development of MPC5748G and using latest sdk of RTM 1.0.0.   Here, example code of LWIP(v2.0.2) has a FreeRTOS based porting and I want to use SafeRTOS instead ...
    Rajani Sureja
    last modified by Rajani Sureja
  • More RADAR Application Examples (related to S32R274 and TEF810X)

    Hi,   We have one RADAR example application (OneRF_4Antennas_demo_s32r274) for S32R274 and TEF810X with the RSDK. We are looking for more examples on RADAR application using S32R274 and TEF810X.    Plea...
    Sushant Susheel Gosavi
    last modified by Sushant Susheel Gosavi
  • How to use the printf on S32K148 boad with S32D studio?

    Dear,        Can someone give a guide on: How to use the printf on S32K148 board with S32D Studio?         Now, on the web, we can found some solutio...
    kongdetao@saicmotor.com
    last modified by kongdetao@saicmotor.com
  • How to correctly step debug in S32DS ?

    Hi, I am developing millimeter-wave radar using S32R274. Now, I want to debug the code step by step through PE . But, the program does not follow C syntax. The version of IDE is S32 Design Studio for Power Architect...
    pingfang
    last modified by pingfang
  • std::vector in S32 & EWL

    I have a strange problem. As soon as I start using a std::vector, I get a link error.   The following code is a simple S32 C++/EWL project: #include <vector> int main() {      counterc...
    Fabrizio Santini
    last modified by Fabrizio Santini
  • 1RF_4Antenna Demo with S32R274 and TEF810X

    Hi,   I am trying to execute 1RF_4Antenna_Demo with TEF810X and S32R274 RRU Board. I followed the reference manual given in Docs folder as well as the description file available with the example project.  ...
    Sushant Susheel Gosavi
    last modified by Sushant Susheel Gosavi
  • newlib_nano under S32 DS

    Hello,   i am trying to create a c++ project under S32DS for KEA128 Controller with newLib_nano no IO. But when i build the project (empty, just main) the code size is about 47k? did i miss anything to set? i di...
    Hani Samara
    last modified by Hani Samara
  • Error when generating code for SCST Lib with S32K116, SDK 2.9.2 and IAR 8.22.2 c

    Hello,   S32DS failed to generate SCST Library code with SDK S32K1xx_BETA_2.9.2 and IAR 8.22.2 compiler with below Error:   Description:    Generator: FAILURE: at line 86: Unknown macro: "PE_G_...
    Minh Pham
    last modified by Minh Pham
  • How can I use S32 DS to compile the C code generated from Simulink model?

    Hello, I bought a Devkit-MPC5744 recently, and downloaded the Model-based Design Toolbox for MPC5744P from the NXP website.   And then I open the example model file from the Model-based Design Toolbo...
    Leo Lyu
    last modified by Leo Lyu
  • S32DS and code management systems?

    I have a customer who started asking how the makefiles are generated for the SDK projects.  Is there any documentation that describes how the makefiles are generated?   Then digging in deeper it is as I ex...
    Daniel Wax
    created by Daniel Wax
  • Shall I press the openSDA switch to enter Bootloader mode when using S32 DS to debug the Devkit?

    Hello, everyone, I bought a Devkit-MPC5744P recently. According to the QSG for Devkit-MPC5744P, maybe I should press the openSDA switch to enter the Bootoader Mode. But according to the SWIG for Devkit-M...
    Leo Lyu
    last modified by Leo Lyu
  • S32DS for S32K116 - Compiler Options

    I noticed when I was creating a new S32DS Application for the S32K116 processor that on the create project first page that there are two compiler options:   - ARM Bare-Metal 32-bit Target Binary Toolchain (comme...
    brucebowling
    last modified by brucebowling
  • S32DS warning failed to execute MI command

    Hi, I had used S32 Design Studio for ARM Version: 2018.R1 to make a project and  Segger J-Link V8 to debug. When I debug the project,whatever singlestep debugging or run function, the pr...
    yu wu
    last modified by yu wu
  • How to run the project on S32 ds with openSDA and Devkit?

    Hey, everyone. I bought a Devkit-MPC5744P recently and download the S32 design studio from the NXP website. It is OK to build an example project and debug the project with the openSDA to the devkit . But when...
    Leo Lyu
    last modified by Leo Lyu
  • How to creat a lib file and add it to another project with S32DS

    Hi  I creat a lib file with S32DS in this way: file->new->new s32ds project->library project ,and in this file , I creat a simple function to test that if it is ok . Then I creat a elf project fil...
    Suomi Chen
    last modified by Suomi Chen
  • sprintf bug when using newlib nano with "-u _printf_float" linker option

    Hello,   I am using S32 Design Studio 2017.R1 for an MPC5777C project. Because of the embedded real-time nature of our project, we are using S32DS newlib nano as the standard "C" library. By default this library...
    Dan Teodorescu
    last modified by Dan Teodorescu
  • Getting started with s32r27

    Hi,   I'm using S32 design studio with SW32R274_RSDK_RTM_1_0_0. I'm able to import projects and run them.   But I'm unable to get "printf" working. I've even tried enabling the macros "UART_ENABLED...
    Chidvilas Y
    last modified by Chidvilas Y
  • S32v234 access 4 channel OV10640 problem

    I refer to the ISP tutorial to modify the ov10635 four-way camera tutorial Mainly to replace OV10635 with OV10640 Added in main.cpp   After the compilation is finished, move the generated .elf to S32V234 an...
    鹏 包
    last modified by 鹏 包
  • Documentations for Parallel Processing in S32V234.

    Hi,       To begin, I have worked with S32V234 and S32 Design studio for vision. Now I have an algorithm like traffic signs detection or pedestrian detection.     I would like to implement the...
    Niranjan ravi
    last modified by Niranjan ravi
  • s32k144,How use printf?

    Hi ! in chip s32k144,How can i use the "printf" in the s32 design? thanks!
    pate lin
    last modified by pate lin