• CodeWarrior TAP Connecting Issues LS1021a

    (1) Debug Mode Bareboard Project: I connected my  TWR-LS1021a eva board via CodeWarrior Tap and to my PC    When I ran into debug mode it throws me this error.   (2) QorIQ Configuration Projec...
    Elias Bitbaker
    last modified by Elias Bitbaker
  • Are there instructions to build images from Yocto for LX2160A RDB?

    Hi, I'm trying to boot up a development kit of LX2160A RDB, and the instructions has several bad instructions using the LayerScape SDK 19.09, so I would like (and rather prefer) to use Yocto builds, having this in min...
    Johan Alexis Duque Cadena
    last modified by Johan Alexis Duque Cadena
  • Layerscape Software Development Kit - v19.09 - How to build OFFLINE using WSL2?

    Hello, I successfully was able to build complete LS1012ARDB image on my corporate computer that is indeed connected to the WAN. This is an easy one since scripts simply can get on the Internet and get missing modules...
    Christophe SCHMID
    last modified by Christophe SCHMID
  • 1021a board bring up replace CPLD with Atmega328P

    Hi Guys,   I have a standalone ls1021a, eMMC, a Atemega328P chipset on the board and a JTAG interface. I want to bring the board up to initiates the power-on reset flow. I am trying to implement the CPLD logic i...
    Elias Bitbaker
    last modified by Elias Bitbaker
  • LX2160A RDB 10 GbE performance

    Seems to me like the 10 GbE performance on the LX2160A RDB is pretty poor. A simple client/server test moving large blocks of data between the LX2160A RDB and another computer using a TCP socket and send/recv produces...
    Ash Law
    created by Ash Law
  • can not ping remote host in Felix switch CPU mode with bridge-LSDK19.09-ls1028ardb

    Hi,   I followed the instructions in LSDK19.09 chapter 8.6.3, but failed to ping 192.168.2.2 remote host from ls1028ardb. The new namespace and br0's IP address are shown as below. (they should be correct). And...
    Yi Yu
    last modified by Yi Yu
  • repo fetch for Optee failed?

    Hello, I am working on LSDK 19.09(flexbuild_lsdk1909_update_221019). I changed the CONFIG_APP_OPTEE=y in configs/buld_lsdk.cfg file, and I was expecting some new directory optee_os, optee_client, and optee_test will...
    Zhenchuan Chai
    last modified by Zhenchuan Chai
  • LS1021A RCW fields clarification (IFC, SYSCLK,QSPI, etc.)

    Hi,   So my boot source is eMMC which is hard wired strapped.   Now back to RCW settings datasheet says   PBI_SRC 1110 is the IFC mode   Then IFC_MODE says cfg_rcw_src[0:8] 0_0100_0000  is...
    Elias Bitbaker
    last modified by Elias Bitbaker
  • [Failed] notification of LSDK19.09 on LS1028ARDB

    Hi all, I deployed the LSDK19.09 by flex-installer successfully. But after I start the system from SD card boot, it continuously report errors as below: " [FAILED] Failed to mount Mount unit for core, revision 6533...
    Yi Yu
    last modified by Yi Yu
  • MCUXpresso replicates -D__MULTICORE_NONE and -D__MULTICORE_MASTER in .cproject file ad infinitum.

    The MCUXpresso IDE keeps adding -D__MULTICORE_MASTER and -D__MULTICORE_NONE to .cproject file:   @@ -1016,7 +1016,7 @@ <tool id="com.crt.advproject.gas.exe.release.1872929933" name="MCU Assembler" superClass=...
    Roger Strassburg
    last modified by Roger Strassburg
  • LS1012A - muxing SPI and GPIO

    Hello,   we're designing a LS1012-based board and we'll be using SPI only to load FPGA configuration, therefore we only need SPI_CLK and SPI_MOSI signals. So, I'd like to know whether it's possible to use the re...
    Luka Pirnat
    last modified by Luka Pirnat
  • How to flash PBL into eMMC of LS1021a via JTAG

    Hi Guys,   Current I have a stand alone ls1021a chipset and external eMMC. I want to flash my image into the eMMC. The first thing I know is to program the PBL (includes PBI and RCW) into the eMMC. Can I use Cod...
    Elias Bitbaker
    last modified by Elias Bitbaker
  • Flex-build Support for MPC-LS-VNP-RDB Platform

    Hi Community,   I am working on NXP's MPC-LS-VNP-RDB development board. NXP Provides documentation for building Yocto images for this board. I have tried that method and sucessfully implemented yocto based ...
    Shashikant Wakale
    last modified by Shashikant Wakale
  • openOCD as ls1021a debugger

    I would like to use openOCD as debug solution for a ls1021a-twr But I could not find any information on this topic. Could openOCD be used as a debugger for an ls1021a target? What debug H...
    Rainer Boschung
    last modified by Rainer Boschung
  • tsntool does not work in ubuntu_mate of LSDK19.09 on ls1028ardb

    Hi all,   I used the command of "flex-builder -m ls1028ardb -r ubuntu:mate" to generate three files: " bootpartition_LS_arm64_lts_4.19_201912101224.tgz firmware_ls1028ardb_uboot_sdboot.img rootfs_lsdk1909_LS...
    Yi Yu
    last modified by Yi Yu
  • Does LSDK support LPM20?

    I test the power management feature by following "11.1 Power management user manual" of LSDK User Guide 1909 on FRWY-LS1046A board.  But I don't see ASLEEP LED is turned on when I run the following command: echo...
    yutaka_ando
    last modified by yutaka_ando
  • Fail to run make menuconfig in LSDK19.09 on ls1028ardb

    Hi all,   I tried to run "make menuconfig" as stated in chapter 7.1 of LSDK1909 manual. But it failed with error information as below. Could you help to comment on this issue?   Thanks,    Yi ...
    Yi Yu
    last modified by Yi Yu
  • compilation failure  flexbuild_lsdk1909_update_221019 "app" component 'weston'

    Hi , I am trying to compile flexbuild_lsdk1909_update_221019 "app" component but I am getting following error :   make[2]: Leaving directory '/NXP/flexbuild_lsdk1909_update_221019/packages/apps/libdrm' Bu...
    Neeraj Mohture
    last modified by Neeraj Mohture
  • ls1021a standalone power reset control signals (JTAG related)

    Hi,   I have a standalone ls1021a and instead of using CPLD to do the board bring up I used atmega328p   Please refer to my below thread as well: 1021a board bring up replace CPLD with Atmega328P  &...
    Elias Bitbaker
    last modified by Elias Bitbaker
  • LS1012ARDB-PC K22 CMSIS DAP USB bootloader bricked

    Good morning all,   I specifically write to ufedor on NXP Kinetis support engineer suggestion. I opened a ticket already: "Case:00242755:We bought a LS1012ARDB board and I bricked to OpenSDA firmware/...
    Christophe SCHMID
    last modified by Christophe SCHMID