• compilation failure  flexbuild_lsdk1909_update_221019 "app" component 'weston'

    Hi , I am trying to compile flexbuild_lsdk1909_update_221019 "app" component but I am getting following error :   make[2]: Leaving directory '/NXP/flexbuild_lsdk1909_update_221019/packages/apps/libdrm' Bu...
    Neeraj Mohture
    last modified by Neeraj Mohture
  • LS1012ARDB-PC K22 CMSIS DAP USB bootloader bricked

    Good morning all,   I specifically write to ufedor on NXP Kinetis support engineer suggestion. I opened a ticket already: "Case:00242755:We bought a LS1012ARDB board and I bricked to OpenSDA firmware/...
    Christophe SCHMID
    last modified by Christophe SCHMID
  • CodeWarrior TAP Connecting Issues LS1021a

    (1) Debug Mode Bareboard Project: I connected my  TWR-LS1021a eva board via CodeWarrior Tap and to my PC    When I ran into debug mode it throws me this error.   (2) QorIQ Configuration Projec...
    Elias Bitbaker
    last modified by Elias Bitbaker
  • LS1012A - muxing SPI and GPIO

    Hello,   we're designing a LS1012-based board and we'll be using SPI only to load FPGA configuration, therefore we only need SPI_CLK and SPI_MOSI signals. So, I'd like to know whether it's possible to use the re...
    Luka Pirnat
    last modified by Luka Pirnat
  • tsntool does not work in ubuntu_mate of LSDK19.09 on ls1028ardb

    Hi all,   I used the command of "flex-builder -m ls1028ardb -r ubuntu:mate" to generate three files: " bootpartition_LS_arm64_lts_4.19_201912101224.tgz firmware_ls1028ardb_uboot_sdboot.img rootfs_lsdk1909_LS...
    Yi Yu
    last modified by Yi Yu
  • LS1021ATSN :uboot can't find 'setenv'

    When I set MAC addresses on the LS1021ATSN-PA board in U-Boot according to  Open Industrial Linux User Guide: This is the command: \0x1b7\0x1b[r\0x1b[999;999H\0x1b[6nroot@ls1021atsn:~# setenv ethaddr 00:04:9f:e...
    qiwen yun
    last modified by qiwen yun
  • How to flash PBL into eMMC of LS1021a via JTAG

    Hi Guys,   Current I have a stand alone ls1021a chipset and external eMMC. I want to flash my image into the eMMC. The first thing I know is to program the PBL (includes PBI and RCW) into the eMMC. Can I use Cod...
    Elias Bitbaker
    last modified by Elias Bitbaker
  • ls1021a standalone power reset control signals (JTAG related)

    Hi,   I have a standalone ls1021a and instead of using CPLD to do the board bring up I used atmega328p   Please refer to my below thread as well: 1021a board bring up replace CPLD with Atmega328P  &...
    Elias Bitbaker
    last modified by Elias Bitbaker
  • Flex-build Support for MPC-LS-VNP-RDB Platform

    Hi Community,   I am working on NXP's MPC-LS-VNP-RDB development board. NXP Provides documentation for building Yocto images for this board. I have tried that method and sucessfully implemented yocto based ...
    Shashikant Wakale
    last modified by Shashikant Wakale
  • Fail to run make menuconfig in LSDK19.09 on ls1028ardb

    Hi all,   I tried to run "make menuconfig" as stated in chapter 7.1 of LSDK1909 manual. But it failed with error information as below. Could you help to comment on this issue?   Thanks,    Yi ...
    Yi Yu
    created by Yi Yu
  • [Failed] notification of LSDK19.09 on LS1028ARDB

    Hi all, I deployed the LSDK19.09 by flex-installer successfully. But after I start the system from SD card boot, it continuously report errors as below: " [FAILED] Failed to mount Mount unit for core, revision 6533...
    Yi Yu
    last modified by Yi Yu
  • LSDK 19.09 Network Problem

    Hello,   I've migrated a running code from LSDK 18.03 to 19.09. The compilation has no errors but when the system boots up, the network interface seemed to malfunction. The dpaa2 object dpni seemed not bound to ...
    Carl Jones
    last modified by Carl Jones
  • 1021a board bring up replace CPLD with Atmega328P

    Hi Guys,   I have a standalone ls1021a, eMMC, a Atemega328P chipset on the board and a JTAG interface. I want to bring the board up to initiates the power-on reset flow. I am trying to implement the CPLD logic i...
    Elias Bitbaker
    last modified by Elias Bitbaker
  • When ls1021atwr connect to 100baseT wire,  803x_aneg_done: SGMII link is not ok

    Our projects have the requirement of eth0/1 use 100BaseT. eth0 or eth1 connect to 100baseT wire, ar8033 auto-negotiation to 100base,  after execute  command the operation of eth down and up, link is not ok, ...
    fu cheng
    last modified by fu cheng
  • CodeWarrior Armv7 ls1021a flash error

    Hi,   So my standalone board of ls1021a which has an external eMMC, DDR no SD card slot option. I want to test the uboot binary on the LS1021A-TWR eva board via JTAG interface first then flash to my stand alone ...
    Elias Bitbaker
    last modified by Elias Bitbaker
  • LS1021ATSN-PA uboot

    I need to start the LS1021ATSN-PA. I have prepare the SD card according to LS1021ATSN-PA Getting Start Guide,when I insert the SD card to the board,I can't see the uboot.what should I do next? I have finished these s...
    qiwen yun
    last modified by qiwen yun
  • Unable to handle kernel paging request at virtual address ffff80a87731a03a

    Hi, I have an error encountered when running some throughput test on my custom board based on LS1043 reference design board.  Here's the error message I get, I couldn't figure out if it's related to the hardware...
    kl h
    last modified by kl h
  • Does LSDK support LPM20?

    I test the power management feature by following "11.1 Power management user manual" of LSDK User Guide 1909 on FRWY-LS1046A board.  But I don't see ASLEEP LED is turned on when I run the following command: echo...
    yutaka_ando
    last modified by yutaka_ando
  • Micorcode of T1040D4RDB

    I am using T1040 D4 RDB kit. Can you please let me know the use of FMAN microcode which is located in NOR flash. when and where does this microcode gets copied to RAM location?
    Sahana S
    last modified by Sahana S
  • Build problem LSDK19.09 for LS-1046AFRWY.

    Hello community,   I try to build all image automatically for LS-1046AFRWY by following command.   > flex-builder -m ls1046afrwy   But, building apps/FMC will stop by link error as following ...
    Takayuki Ishii
    last modified by Takayuki Ishii