• LS1046ARDB usb peripherial mode works at usb2.0 mode ?

    I have a LS1046ARDB EVK and the kernel version is 4.19.68. I tried to work USB 3.0 Type-A as peripheral mode to simulate as USB device to connect to PC   The device tree is set as below: usb0: usb3@2f0000...
    Andy Hsu
    last modified by Andy Hsu
  • LS1012A-frwy use QCA6174  as 5Ghz AP failed!

    Hi,  my board is ls1012a-frwy, I  can use QCA6174 802.11ac Wireless Network Adapter scan and link 5G wifi, but  when I use it to work in 5G AP mode,  the kernel get the error "ath10k_pci...
    hber hber
    last modified by hber hber
  • We made a board based on 1046ardb and used 485. How can I modify rcw and device tree to use it?

    We made a board based on 1046ardb and used 485. How can I modify rcw and device tree to use it?
    xian gang
    last modified by xian gang
  • Port pin status during RESET

    What is the port pin status of ball E13 "IFC_PAR1/GPIO2_14/QSPI_DIO_B1/FTM6_CH1", while LS1021A is set into RESET state? Datasheet (Rev. 7, 06/2019) doesn't provide any notes for this pin. Is there any inte...
    FK
    last modified by FK
  • crypto_aead_aes256gcm_is_available return 0 on ls1021a

    LS1021a TWR Eva Kernel 4.19 Debian distro   Hi,   I am trying to use AES256-GCM crypto mechanism to achieve encryption and decryption on my eva kit.    But when I run    if (cry...
    Elias Bitbaker
    last modified by Elias Bitbaker
  • LS1021A SEC CRCA Dynamic Custom Mode

    LS1021A, I use SEC for hardware CRC calculation, I can only run the STANDARD IEEE and IETF mode correctly, when it comes to Dynamic CUSTOM mode, the hardware will generate all ZERO results. The register configuration ...
    wang XiNan
    last modified by wang XiNan
  • Connecting LS1020A SGMII to 1000BASE-X w/o PHY?

    Hi in our system we use 1000BASE-X (w/o electrical-to-optical converter, full duplex, fix rate, no AN) for on our backplane ethernet communication. For the design of a new module we selected the LS1020 as board contr...
    Rainer Boschung
    last modified by Rainer Boschung
  • LS1046AR is directly connected to PC issue

    The LS1046ARDB is connected to PC via IP router and it is work LS1046ARDB <--> IP Router <--> PC I try to connect both directly but I can get the ping value. LS1046ARDB   <---> PC  ...
    Andy Hsu
    last modified by Andy Hsu
  • i2c4 bus dead on ls1023a

    We are using the ls1023a on a custom board derived from the ls1043ardb.    my dtsi has: i2c3: i2c@21b0000 { compatible = "fsl,vf610-i2c"; #address-cells = <1>; #size-cells = <0>; reg = <...
    Dan Lenz
    last modified by Dan Lenz
  • Reassy problem with LS2088 AIOP

    Hi,   I'm trying to implement hardware assisted reassy on LS2088 AIOP. It is now working stable with low data rates (few hundreds of megabits per second), but when using higher data rates I got these kind of err...
    Wille Kuutti
    last modified by Wille Kuutti
  • How to fix ECC of DDR4 training address after warm boot?

    Hi, I have a custom board with an LS1046A and 4GB DDR4 ECC memory and U-Boot. I successfully found a way to perform a 'warm' reboot (preserving DRAM contents) by setting the FRC_SR bit of the DDR_SDRAM_CFG_2 re...
    Ruud Pendavingh
    last modified by Ruud Pendavingh
  • Unable to write to SecMon HPSVCR

    Hi, We have a setup with secure boot running (RCW[SB_EN] = 1) with our custom boot code on LS1046ARDB using Flow B outlined in LSDK Documentation. We would like to test authentication failure case where the boa...
    Shivesh Sood
    last modified by Shivesh Sood
  • LS1046A RDB not booting: mbed problem?

    I've just setup my LS1046A RDB kit and followed the Getting Started Guide: Downloaded and installed the mbed serial port driver and installed Tera Term, When connecting the USB cable between console port and PC, Win...
    Ruud Pendavingh
    last modified by Ruud Pendavingh
  • LS1012ARDB - PCIe IO Coherency

    First some context: I am connecting an AMD Radeon GPU to the LS1012ARDB's mini PCIe slot in order to get it working with linux. The GPU is visible on the PCIe bus, enumerates, gets it's BAR's assigned, and is recogni...
    Bas Vermeulen
    last modified by Bas Vermeulen
  • LS1043ardb, how to enable ethernet 10G and USB port ?

    I am trying to connect to the internet throught 10 G port and i want to increase the storage space using USB port. If anyone has idea how about, how to do it ? please help me with that. #ls1043ardb #ethernet #usb
    ganeshkannan iyyanr
    last modified by ganeshkannan iyyanr
  • LS1021a PCIe port error

    Has anyone encountered this error ever before?   I am not able to boot into the rootfs.   Kernel 4.19 Debian distribution   [  172.125566] Internal error: : 1210 [#1] SMP ARM [  172.1...
    Elias Bitbaker
    last modified by Elias Bitbaker
  • LS1012A SerDes

    Hello,   I'd like to know whether it's possible to have the LS1012 SerDes configured to have both the 2.5G SGMII and RGMII (MAC2). Based on Table 28-2 in the Ref. Manual the SGMII 2.5G and RGMII are mutually exc...
    Luka Pirnat
    last modified by Luka Pirnat
  • During prototyping, can secured boot functionality be tested without blowing fuses?

    Hi, I would like to know a temporary way of provisioning SRKH Register(without blowing the fuses) and executing secured boot. I am aware of SFP SRKH Mirror Registers being mapped to 0x01E80254 location onwards....
    Rashmitha Ramesh Nair
    last modified by Rashmitha Ramesh Nair
  • fail to run ./pktgen_twoqueue.sh,pgctrl does not exists on LS1028ARDB

    Hi all,       When I follow the "7.1.3.2.3 Qbv performance test Use" in Open Industrial Linux User Guide, Rev. 1.6, 08/2019, it failed to execute the command of "qbvset --device eno0 --entryfile...
    Yi Yu
    last modified by Yi Yu
  • Setting up Freeway LS1046-AC

    Hi all,               I need help in setting up the following regarding the Freeway #LS1046-AC board.            &#...
    Cris Thomas
    last modified by Cris Thomas