• No Ethernet ports while creating new DPMAC with ls-addni

    I am facing problem while creating the new DPMAC object. if i use dynamic_dpl.sh script file to create the new DPMAC object ,l2fwd or any example application can successfully detect this DPMAC as Ethernet port. But ...
    Prabhat Kumar Shukla
    last modified by Prabhat Kumar Shukla
  • LX2160A RDB uboot log issue

    I have an LX2160ARDB (just started with it). The system seems to boot up fine from the default load. When I set SW1 to try and boot off the SD card (SW1 set to 1000 1000) I get no uboot log on the terminal. Any ideas ...
    Ash Law
    last modified by Ash Law
  • Does LSDK support LPM20?

    I test the power management feature by following "11.1 Power management user manual" of LSDK User Guide 1909 on FRWY-LS1046A board.  But I don't see ASLEEP LED is turned on when I run the following command: echo...
    yutaka_ando
    created by yutaka_ando
  • How to use SFP transceiver in SFP+ cage in LS1046ardb

    Hi, all I'm trying to use SFP module in SFP+ cage in LS1046ardb, but it's not working. I found some information (https://community.nxp.com/message/1232605?commentID=1232605#comment-1232605 ) in this community, ...
    JS Park
    last modified by JS Park
  • LSDK for LX2160ARDB ipv6 router solicitation packets flooding network

    I have tried everything anyone has suggested to turn off ipv6 on this board.   Tried /etc/sysctl set to :   net.ipv6.conf.all.disable_ipv6 = 1 net.ipv6.conf.default.disable_ipv6 = 1 net.ipv6.conf.lo.disabl...
    Ash Law
    last modified by Ash Law
  • Reassy problem with LS2088 AIOP

    Hi,   I'm trying to implement hardware assisted reassy on LS2088 AIOP. It is now working stable with low data rates (few hundreds of megabits per second), but when using higher data rates I got these kind of err...
    Wille Kuutti
    last modified by Wille Kuutti
  • How to boot linux image once and for all

    I finish boot up the system,and execute the following commands to TFTP the images to the board, then boot into Linux.  =>tftp 1000000 <uImage_name>  //uImage-t4240qds.bin     =>...
    丁 凡
    last modified by 丁 凡
  • LS1021A SEC CRCA Dynamic Custom Mode

    LS1021A, I use SEC for hardware CRC calculation, I can only run the STANDARD IEEE and IETF mode correctly, when it comes to Dynamic CUSTOM mode, the hardware will generate all ZERO results. The register configuration ...
    wang XiNan
    last modified by wang XiNan
  • Dose LS1046 support USB gadget mode on USB 3.0 (5Gpbs)?

    I am working on USB 3.0 gadget on LS1046ARDB. I see LS1046ARD document "QorIQ LS1046A Product Brief"   The USB 3.0 module operates in following modes: • Host Mode: SS/HS/FS/LS • Device Mode: SS/HS/FS...
    Andy Hsu
    last modified by Andy Hsu
  • How to run Code Warrior ARMv7

    Hi,   I just downloaded CodeWarrior for ARMv7 version 10.0.9 b190131 Windows Online Installer   But how am I able to run it since I encountered license errors    Do I need to purchase the l...
    Elias Bitbaker
    last modified by Elias Bitbaker
  • Error: Unrecognized opcode: `mtpmr'

    Hi,everyone,I had a problem when I cross-compile with commond I use "make ppc6xx_defconfig",it supposed to have a .config file ,but I couldn't find it. In the next step,I use "make uImage",it shows Error: Unrecogniz...
    丁 凡
    last modified by 丁 凡
  • configure the serdes of ls1012a to base1000-KX mode.

    Hi team,     The processor we are using is ls1012a, and the code used is open source flexbuild_lsdk1812_update_010719. I read the document "Document Number: LS1012ARM Rev. 2, 02/2019" and learned that the se...
    李 李
    last modified by 李 李
  • Could you advice how to deploy TF-A binaries in QSPI on LS1043A/23A"?

    Hi Experts:   We want to know, how to deploy TF-A binaries in QSPI on LS1043A/23A. I find the following explanation in community.   <LS1043ARDB - How to deploy TF-A binaries in NAND flash> https://c...
    Kazuya Yamauchi
    last modified by Kazuya Yamauchi
  • LX2160ARDB and BSP  Documentation

    Both these guides as downloaded from the website seem to have a lot of errors. To the extent that I'm not sure of what I'm doing. I'm trying to get a load of Linux user stuff onto an SD card.   Following the dir...
    Ash Law
    last modified by Ash Law
  • LS1012A Cannot login automatically as root

    Hi!      I want to login automatically as root after the system boot and no password required! I've tried modify “/lib/systemd/system/getty@.service” content a...
    li yh
    last modified by li yh
  • Connecting LS1020A SGMII to 1000BASE-X w/o PHY?

    Hi in our system we use 1000BASE-X (w/o electrical-to-optical converter, full duplex, fix rate, no AN) for on our backplane ethernet communication. For the design of a new module we selected the LS1020 as board contr...
    Rainer Boschung
    last modified by Rainer Boschung
  • Access to Configuration registers for SPI

    Hello,   How can I access directly to the configuration registers for the SPI module? For example, register SPIx_MCR, for configure Fast Continuous Selection Format.   I have tried with IOCTL functio...
    Jesus Gutierrez
    last modified by Jesus Gutierrez
  • Gaps between bytes SPI

    Hello, I'm using LS1021a micro and when I transfer data from QorIQ, in out signals I get the attached picture (yellow = clk, green = cs) There is a large gap between bytes and it is not always the same. I would ...
    Jesus Gutierrez
    last modified by Jesus Gutierrez
  • ls1043 run dpdk l2fwd sample error

    ls1043 run dpdk l2fwd sample error #l2fwd -c 0x2 -n 1 -- -p 0x1 -q 1 -T 0 EAL: Detected 2 lcore(s) EAL: Detected 1 NUMA nodes EAL: Multi-process socket /var/run/dpdk/rte/mp_socket EAL: Probing VFIO support... E...
    Xiaofan Lee
    last modified by Xiaofan Lee
  • Prebuilt Images for LS1046ARDB page is not identified

    Hi all, I have LS1046ARDB board, mentioned in "getting started guide"  https://www.nxp.com/docs/en/application-note/AN5340.pdf  get the pre built images from one of link, but it is not available &...
    Ashish Kumar
    last modified by Ashish Kumar