• FreeRTOS version in MCUXpresso

    Hi,   I downloaded a SDK from NXP website. How can I know the FreeRTOS version in this SDK?   Thank you.
    David Zhu
    last modified by David Zhu
  • FreeRTOS with SDcard

    Hello,   I am using Kinetis K64.  I am using FreeRTOS on this design.  I want to use SD card with FFS.   Can you give me some advice on how to do this, Any examples on this?   Thank you
    David Zhu
    created by David Zhu
  • Why is "printf" not working when configuring STDIO with IO_SERIAL_NON_BLOCKING flag?

    I'm trying to configure STDIO with the "IO_SERIAL_NON_BLOCKING" flag because I need the reception not to block waiting for X amount of characters. I have added the IO_SERIAL_NON_BLOCKING flag in the...
    Manuel Malagon
    last modified by Manuel Malagon
  • Why is "IO_IOCTL_CHAR_AVAIL" only working when receiving 1 byte (UART)

    Hello   I have a project where I use my board's UART4 with the stdio and I can "printf" just fine. Additionally, I need that very same port for another part of my project so in my code I open it with:   po...
    Manuel Malagon
    last modified by Manuel Malagon
  • Guide for working with MQX in MCUXpresso

    Introduction and Assumptions     I'm creating this little tutorial because I haven't been able to find anything better for doing this. I will explain how I work with MQX using MCUXpresso, it's not perfect, b...
    Daniel Chen
    created by Daniel Chen
  • Freescale MQX™  4.1.1 GA Release - Linux Tip

    I'm working right now with MQX 4.1.1 in a project that was started in 2016 so that's why. Anyway, recently I came across this post; Freescale MQX™ 4.1.1 GA Release which helped me to find MQX for build...
    Manuel Malagon
    last modified by Manuel Malagon
  • Relocating Interrupt Vector Table When Using MQX

    I can import an example Kinetis K64F Freedom board (FRDM-K64F) bareboard project, modify its linker file to something like the following (that is, relocate its interrupt vector table), and it still works fine:   ...
    kackle123
    last modified by kackle123
  • MQX SW Watchdog

    Dear List, I am using TWRK64 board with MQX4.2 on KDS V3. I was looking into the watchdog example(the only reference for MQX Watchdog I could come across!). The _watchdog_XXX APIs are poorly documented and there is n...
    CSMG Sarma
    last modified by CSMG Sarma
  • MQX kernel ISR vs MQX managed ISR

    Interrupts can be handled by MQX (MQX managed ISR) or bypassing MQX (MQX kernel ISR). If you want that MQX handled all the ISR process, you can use MQX managed ISR.  By this ISR,  MQX catches all hardware in...
    Daniel Chen
    last modified by ebiz_ws_prod
  • about MQX interrupt uart

    Hey ,every one I find a problem about interrupt uart in MQX .I use K60 microcontroller.   Now I can receive data from ISR. but when I send bytes to Computer. I just receive one byte in Computer. even if I send o...
    HAOYUAN CAI
    last modified by HAOYUAN CAI
  • Printf redirection in MQX

    Hi, I am using TWR-K65F180M with MQX in IAR workbench. The MQX takes over the IO and redirects it to Serial port. I would like to display it in the IDE using JTAG. How do I disable this default MQX redirection ? o...
  • k70 with MQX 4.1 . SD card read issue (For bigger file Size > 1MB)

    I am trying to read data from SD card (Sandisk 4 GB) using eSDHC driver . I am not able to read complete file if file size is more than 1 MB..   I tried below: 1) decrease the speed in the sdhc conf structure (...
    soham dandapat
    last modified by soham dandapat
  • MAC57D54 GIC register

    I built a project.of S32DS.ARM,its process is MAC57D54.But i Can not find the register of A5 Core.This is my first question.And my Second Question is how to Create a Interrupt to A5 Core using GIC.
    yang zhang
    last modified by yang zhang
  • weston login not accepting keyboard input using oled(/dev/fb0)

    1. login prompt missing from oled ( /dev/fb0) 2. weston --tty=1 --use-gal2d=1 --use-gl=0 --device=/dev/fb0   -- causes login prompt on the oled(/dev/fb0) 3. no input seen from the usb wireless keyboar...
    Terry Buckley
    last modified by Terry Buckley
  • Can I call _lwmsgq_send from an ISR?

    Sorry for the question but I come from a FreeRTOS environment and that RTOS has a different set of APIs that shall be used if you need to call an RTOS API from an ISR. I know that MXQ and FreeRTOS are totally dif...
    Manuel Malagon
    last modified by Manuel Malagon
  • TCP child task gets stuck at send()

    MQX ver. 4.1.1. I made a daemon server to treat incoming TCP connections as suggested in many posts by NXP mods. I set a limit of connections to 5 using my own solution and that's working alright. The problem i have ...
    Alvaro Oliveira
    last modified by Alvaro Oliveira
  • CRC calculation of read buffer / flash incorrect with data caching enabled

    Hi All,   I am trying to debug a problem in our product based on Kinetis K70 (revision 3) and MQX 4.1.   This is what I am doing - 1. Write N bytes to a memory location in external memory (DDR) or program...
    Shreyas Balakrishna
    last modified by Shreyas Balakrishna
  • _esdhc_read, SD, and cache?

    My environment:  MQX 4.1, MFS, K70FX, eMMC, DDR   I'm writing a small ascii file to MFS installed over the SD card driver.  When I try to display the contents of the file (using the "type" shell comman...
    pbanta
    last modified by pbanta
  • Protected Management Frames (PMF) 80211W support?

    Dear Sir,     I wonder that if sabresd_6dq support 802.11w (pmf), I tried  modfied driver to add pmf feature and set right option in wpa_supplicant.conf while using the wpa_supplicant which complied wi...
    hung jerry
    last modified by hung jerry
  • How to properly configure UART0 for MQX 4.1?

    Hello,   I recently migrated my product from MQX 4.0 on MK60DX256 to MQX 4.1 for chipset MK64FN. One of the issues I have encountered is that the UART0 is not transmitting the correct amount of bytes t...
    derrek velazquez
    last modified by derrek velazquez