• Can SDAC work in wraparound mode with DMA in MPC5777C??

    Below code snippets is for sdadc in wraparound mode (taking data from channel 0->1->2->3) and then storing in an array with four elements. I'm facing synchronization issue, since here we don't have much cont...
    Md Abul Fazal
    last modified by Md Abul Fazal
  • Error Code: Out of Memory (0x0004), State Blocked

    I have an MQX4.1 application running under Codewarrior V10.6 on a K60 processor. It's a custom card and we're using the USB port as a device to connect the equipment to a PC.   The PC isn't connected at the mome...
    Ken Armitage
    last modified by Ken Armitage
  • Guide for working with MQX in MCUXpresso

    Introduction and Assumptions     I'm creating this little tutorial because I haven't been able to find anything better for doing this. I will explain how I work with MQX using MCUXpresso, it's not perfect, b...
    Daniel Chen
    created by Daniel Chen
  • Freescale MQX™  4.1.1 GA Release - Linux Tip

    I'm working right now with MQX 4.1.1 in a project that was started in 2016 so that's why. Anyway, recently I came across this post; Freescale MQX™ 4.1.1 GA Release which helped me to find MQX for build...
    Manuel Malagon
    last modified by Manuel Malagon
  • CyaSSL embedded SSL now available for MQX!

    Hi!   yaSSL is happy to announce that the CyaSSL embedded SSL library now supports MQX/RTCS/MFS as well as the Kinetis MCU and H/W RNGA.  To supplement the port, we have also released several example CodeWa...
    Chris Conlon
    last modified by Chris Conlon
  • MPC574xP AUTOSAR 4.0 MCAL(ISO26262)

    How to get Registration Code?https://www.nxp.com/webapp/swlicensing/activateEntitleHome.sp
    俊鹏 邱
    last modified by 俊鹏 邱
  • PCB Free 0

    Hi,   I'm using MQX 4.2 and I'm wondering how we can have no free pcb's but the limit has not been reached?     Regards, -Mike
    last modified by Mike_d
  • Problems with D4D library

    Hi, I have been trying to compile a projecto with the D4D Library. I'm using CodeWarrior 10.7, MQX 4.0 and the module k40x256. I'm new on that, but I have done the steps given by the AN4644 guide. I solved many of the...
    Alejandra Artal
    last modified by Alejandra Artal
  • Supporting multiple HID device class instances (via HUB class)

    I would like to create a MQX USB host application which supports attachment of multiple HID-class USB devices (several device instances of the same class) connected through a USB hub. There are MQX USB HID example app...
    Gordon Finlay
    last modified by Gordon Finlay
  • TAD blank according to stack size

    Hi,   I'm working with custon MK21FN1M0 board with MQX 4.2.0 (udated was done) on KDS 3.2 on windows 10. I'm debugging with PEMicro (Multilink)   I'm facing a strange behaviour using TAD. I've tas...
    Jeremy Esquirol
    last modified by Jeremy Esquirol
  • MCF52259 ADC under MQX, but with no driver

    Hi, I'm working on a board based upon M52259demokit design, MQX 3.8.1. I need ADC conversions at the fastest speed (5Mhz clock). I tried compiling my project rebuilding the bsp and psp libraries with BSPCFG_ENABLE_ADC...
    Marco Fratini
    last modified by Marco Fratini
  • GPRS demo - FRDM-K64F vs MQX 4.2 vs BGS2T modem - working now

    Hi, I realy wanted to make the demo work on my FRDM-K64F with BGS2T connected to UART4, now it seems I made it, here are the steps needed:   1. copy project/wsd rtcs_gprs_twrk60n512  and make necessary mod...
    Martin Kozusky
    last modified by Martin Kozusky
  • MQX 3.8.1 I2C Master mode question

    Hi, I meet some problem when I use MQX I2C. The environment is [MQX3.8.1] & [CW10.2]. I2C mode is master mode.   1. I would like to read one byte, but it transmit 2 bytes. I have searched the informat...
    Mini Wang
    last modified by Mini Wang
  • Re: How To: Get Started with MQX RTOS for Kinetis SDK v1.1

    Hello Mac,   This is an excellent getting started guide for MQX for Kinetis SDK. I was able to compile and test the MQX demos by following the step by step guide. But besides compiling the "existing" example pr...
    Panfeng Jiang
    last modified by Panfeng Jiang
  • the USB MFS hot un-plug issue

    Some issue found on mqx4.0/mfs/examples/mfs_usb: The fatfs failed to be remounted if unplugging the USB disk when copying files. Actually, when unplugging, the files opened must be closed, otherwise the MFS failed to...
    Jerry Fan
    last modified by Jerry Fan
  • MQX with KSDK and Processor Expert

    The Freescale MQX RTOS is transitioning to use the Kinetis Software Development Kit (KSDK), and there is a Beta release of MQX for KSDK available now.  See Beta version of MQX RTOS for Kinetis SDK - Now Available...
    Derek Snell
    last modified by Derek Snell
  • Minimal code/ram config for 52212 MQX CDC

    Freescale lists that the MQX RTOS with USB stack requires 10K of RAM and 32K of code.  Unfortunately the 52212 only has 8K of RAM.  Because of this, the vanilla off the shelf 3.8.0 MQX stack will not work.&#...
    last modified by Hspahr_89north
  • MQX 4.2 k60 RTC issues SetTime() adds 7~8 Minutes after power cycle

    Hi Everyone,    So i have been having a rough go at getting the RTC to function properly under MQX 4.2.   A little background: We are have been using the k60 for awhile now, and previously used MQX 4...
    Jason Scott
    last modified by Jason Scott
  • MQX RTOS, passing parameter(s) to Auto start tasks! How?

    Hello everybody, this might be a very simple one, but I don't know it.  I know how to pass parameter to a task which is created inside other task susing :   _task_create(blabla, blabla, (uint32_t) pa...
    Roosbeh Almasi
    last modified by Roosbeh Almasi
  • How do I get printf output to a console?

    How do I get printf() output to show up in a console window when debugging an application? Codewarror 10.1 and MQX 3.7.
    Greg Loucks
    last modified by Greg Loucks