Bonny Kurui

Installing Mcuxpresso IDE in Ubuntu 19.04

Blog Post created by Bonny Kurui on Jul 3, 2019

I think this might be late since I was using Ubuntu 18.04 until recently when I upgraded to latest version 19.04

Tried to install Mcuxpresso IDE I encountered some dependency errors but managed to solved it. I had already replied to question about it but decided #to write main post about it.

 

This is what I did (installed the dependencies)

(my laptop is 64 bit)

sudo apt install libusb-1.0-0-dev

 

sudo apt install dfu-util

download  amd64 build of icu 60.1-1 

install the package (open terminal from the file location)

sudo dpkg -i libicu60_60.1-1ubuntu2_amd64.deb

download libjavascriptcoregtk-1.0-0_2.4.11-4

and install

sudo dpkg -i libjavascriptcoregtk-1.0-0_2.4.11-4_amd64.deb

download libwebkitgtk-1.0-0_2.4.11-4

and install

sudo dpkg -i  libwebkitgIDEIDEtk-1.0-0_2.4.11-4_amd64.deb

install IDE(open terminal from file location)

install.....

sudo chmod  +x ./mcuxpressoide-11.0.0_2516.x86_64.deb.bin

sudo ./mcuxpressoide-11.0.0_2516.x86_64.deb.bin

After this you should home and dry 

Everything worked well.

If you have any problem you can reply to this post.

Outcomes