• Pin symbols aren't generated anymore with version 8.0

    Whereas the version 7.0 of the tool generated nice symbols for the pin ports and numbers, they aren't present anymore in the generated pin_mux.h header. This is happening to me on an i.MX RT1010 device.
    Benedek Kupper
    last modified by Benedek Kupper
  • SDK 2.8.0 missing Linux Host in Getting Started

    SDK 2.8.0 SoC: i.MX 7ULP Host: Linux Tools: ARM GCC   Customer: Rockwell    Defect: Documentation missing Arm Tool chain and running on Linux host.   Step 1: SDK Builder, selected GCC ARM Too...
    Curtis Wald
    last modified by Curtis Wald
  • MCUXpresso Config Tools v8 Now Available

    We are pleased to announce that MCUXpresso Config Tools v8 are now available.   MCUXpresso Configuration Tools is a product with set of tools that help users of all levels with a Cortex-M-based MCU solution. Fea...
    Petr Struzka
    last modified by Petr Struzka
  • LPC55S16 and config tool

    I'm trying to start a new project using SPI on a LPC55S16 in MCUXpresso. I Select pins and peripherals in the Config Tools built into MCUXpresso. However, on the overview screen it says "Tools not supported for the se...
    inventthings
    last modified by inventthings
  • Bug Report - CADC Peripheral Configuration

    Project is for the KV46 device.  SDK version 2.8.0 (366 2020-07-21).    Two typos found...   #1 There appears to be a typo in the fsl_cadc.h file for the zero crossing enumerations.  The 'C...
    Patrick Johnson
    last modified by Patrick Johnson
  • is JN5189 supported by the config tool?

    When I try to configure the pins in the config tool for the jn5189dk6_zigbee_ed_rx_on_bm demo project I get an error:     Issue: Processor core 'core0' detected in MCUXpresso_IDE project does not match wit...
    jacintomoreno
    last modified by jacintomoreno
  • MCUXpresso Config Tools - Release History

    This post will include a history of releases for the MCUXpresso Config Tools.    Most Recent Release: MCUXpresso Config Tools v8 - Released on July 21, 2020   Download Links: MCUXpresso IDE with int...
    Clark Jarvis
    last modified by Clark Jarvis
  • Why does the MEX file bound to an EWARM project always need internet access?

    Hello, I have got the same error message as in How to repair MCUXpresso Config Tools? again. After trying different stuff on my PC a co-worker opened the same MEX file on his computer and it worked without any error ...
    Stefan Mitterhauser
    last modified by Stefan Mitterhauser
  • MCT 7.0 - MCT refuses to open for new project

    I've just created a new RT1064 project.  When creating the project, I selected the CVJ5A variant of the RT1064.  My project builds and links correctly.  Now I want to customize the pins and clocks for m...
    David Rodgers
    last modified by David Rodgers
  • MCU 11.1.1 / MCT 7.0.0 - Pins GUI gets confused when sorting

    Ran into a weird bug here... it appears that the Pins display can get seriously confused when sorting using the Label column, such that the Pin and Pin Name columns no longer match up with the rest of the columns....
    David Rodgers
    last modified by David Rodgers
  • LPC55S69 USBHSD - auto-gen chirp/timer bug?

    Using the MCUXpresso Config Tools with LPC55S69, I can get USBHSD code generated (using the CDC VCOM preset). This is awesome!   I've noticed that (a) MRT is required (b) code wrapped by #if CHIRP_ISSUE_WORKAROU...
  • Cannot Import Processor Data

    Having downloaded the data archive from the website, I'm not able to import the processor data for the MCIMX6XxxVN. Having selected the zip archive, I don't have any processors to select and import. I have been a...
    Sam Waggett
    last modified by Sam Waggett
  • Config Tools Data for KL81 Processors

    Can the KL81 processors be configured using the MCUXpresso Config Tools? I can't find the processor data within the software or via the web portal.   Specifically I'm looking for MKL81Z128VMC7.   Thanks fo...
    Sam Waggett
    last modified by Sam Waggett
  • PWMA/eFlexPWM Config Tool - Possible Bug

    Environment: MCUXpresso v11.1.1 Build 3241 Device: MKV46F256VLL16 SDK:  v2.7.0   I am configuring the PWMA/eFlexPWM module using the Config tool for two submodules, both using a complementary A/B PWM out...
    Patrick Johnson
    last modified by Patrick Johnson
  • Cyclic ADC Channel Numbering - Possible Issue?

    I am using MCUXpresso v11.1.1 Build 3241.  I am using SDK v2.7.0 for the KV46.  I am developing for the KV46F256VLL16 microcontroller.   I am configuring the Cyclic ADC peripheral using the Config Tool...
    Patrick Johnson
    last modified by Patrick Johnson
  • MCUXpresso config tool command line dont work

    Hi, I created a new project in: MCUXpresso IDE v11.1.1 [Build 3241] [2020-03-02] and tried to autogenerate bsp files using command line and standalone version of MCUXpresso config tool: Version and Build id: 7.0.0....
    squareroot
    last modified by squareroot
  • Possible bug in pin configuration tool?

    Hello all,   I've noticed what may be a bug in the pin configuration tool in mcuxpresso.   I've been using it with a '824. After selecting a pin to configure the lower panel generates default options for t...
    leo838
    last modified by leo838
  • MCUxPresso Export Bug

    I have discovered that the export function does not match the current routed pins window. It seems once a pin has been routed and labeled, even if it is unrouted and/or relabeled, the original data shows up in th...
    Gerry Kurz
    last modified by Gerry Kurz
  • There will be SDK update for

    There will be SDK update for  SDK_2.2.0 from MK20DX256xxx10 to higher version?    A ask that, because a desire to uso config flexcan on config tool from MCUXpress 11 , but a receive this message:  ...
    DANIEL ALVARENGA
    last modified by DANIEL ALVARENGA
  • Need help with DMA and UART in new project

    I am new to MCUXpresso and am trying to build a project using the config tools.  When I try to use a UART peripheral with DMA I get errors in the peripheral editor for the UART that says that I don't have the DMA...
    William Wolthuis
    last modified by William Wolthuis