• How can use printf function?

    Hi everyone, I want to use printf() for debug. My environment, LPCXpresso IDE ver 822_650 and target cpu LPC11U14. I success to use printf() for the  LPCXpresso C Project and the Manage linker Script is Nwelib(...
    Fumio Yoshizawa
    last modified by Fumio Yoshizawa
  • LPCXpresso LPC1769 (OM13085) Can't find debug Probe

    Hi, I am using MCUXpresso IDE, I connected the board to my computer, using an USB cable. But when I try to launch de debug session, the Probe discovery tool can't detect any device.   On the computer, I can fi...
    Simon BERTIN
    last modified by Simon BERTIN
  • How to choose the right parser on a Mac? / Binary Parser / LPC1115

    Hi everybody,   my intention is to program in C simple projects to learn how to program the NXP LPC1115 using C; then build, download, and debug the result using LPC-Link.   As a beginner I experience lots...
    Andreas Schmidt
    last modified by Andreas Schmidt
  • LPC-Link & Windows 10 driver Problem

    Hi, I've install LPCXpresso v8.2.2 [Build 650] [2016-09-09]  in a Windows 10 - 64 bits PC. When I've connected LPC-Link1 to the USB, LPCExpresso does not recognize it. I've deleted the driver Driver and then c...
    Gustavo Minnucci
    last modified by Gustavo Minnucci
  • Need advice: Can't flash and debug with LPCXpresso.

    Today, I just get error when flashing (use Program Flash) and debugging. below is the error message:   I use: LPC812 Max Board, LPCXpresso v8.2.2 [Build 650] [2016-09-09] Software.   LPCXpresso RedlinkMult...
    heru setiawan
    last modified by heru setiawan
  • LPCXpresso versioning with Git (tutorial)

    Hi, I want to share with the community this tutorial I just finished for versioning our projects. The tutorial can be reached here:   https://fjrg76.wordpress.com/2017/08/04/versioning-lpcxpresso-with-git/ ...
    Fco. Javier Rodriguez G
    last modified by Fco. Javier Rodriguez G
  • pwm on the lpc1115 via om13087 board

    I'm struggling to get PWM working on this board.  I'm using lpcxpresso and my code is below.  My goal is to have the blue LED on pin 28 of the board to blink along with the PWM signal (50% duty cycle so...
    Justin Sconza
    last modified by Justin Sconza
  • LPCXpresso software version for LPC2129?

    I have a LPC2129(ARM7) board with me, I want to use LPCXpresso IDE for the hex generation. But when I tried with the latest software version the hex is not running in my board. Do I need to use any specific older vers...
    Ramakrishnan Arumugam
    last modified by Ramakrishnan Arumugam
  • LPCXpresso: Unable to add a header file (undefined reference error)

    Hi!   I am trying to separate led code in a different file and I am facing following issues:   Issue #1    I Created a new folder by    Right clicking project -> New...
    kembed
    last modified by kembed
  • Project GIT integration - Which files?

    Hello guys.   I've successfully installed eGIT into my LPCXpresso v8.0.0 [Build 526] and starts to track my C/CC+ source files. But currently I'm only able to control source files (.c, .cpp, .h); not the project...
    Diego Barile
    last modified by Diego Barile
  • Linker cannot find __sys_readc, and shouldn't be looking for it

    I am using LPCxpresso for a target of LPC824M201JDH20. It is our board, not a development board. I can get another project to run and emit characters out the USART0 and 2.   But with the main project code the Li...
    Norman Jones
    last modified by Norman Jones
  • License restriction

    Hi,   I have installed LPCexpresso (Version: LPCXpresso v5.0.14 [Build 1109] [2012-12-19] ) on a WindowsXP SP3 machine, and build a project", then try to start debug.   But the dialog says,  ...
    Denny Kluts
    last modified by Denny Kluts
  • Breakpoing in ISR crashes NXP version of GDB

    Hi there, I am having debugging issues with lpcxpresso version 8.2.0. It may affect version 8.1.4 as well. The issue is with an LPCOpen based project on the LPC11U68 although I have noticed similar problems on an LP...
    Mike Cruse
    last modified by Mike Cruse
  • LPCXpresso compilation issue for JN517x ZigBee 3.0

    Hi,  I am evaluating the solution of ZigBee 3.0 in JN517x platform but I have difficulties in compiling the solution in LPCXpresso for JN-AN-1216 example. On compiling the original source code I got the followi...
    Trevor Tam
    last modified by Trevor Tam
  • LPCXpresso Pro Flash size limited to 8K

    Hi,   I am using LPC Xpresso 8.1.4_606 with a Pro license installed. It used to work fine, all of a sudden its not allowing to flash more than 8K image size. I have tried debugging using FAQs, the csript works...
    Ram Gutta
    last modified by Ram Gutta
  • Error installing LPCXpresso 8.2.2 under Fedora 26

    Hello, I'm trying to install LPCXpresso 8.2.2 under fedora 26 but I get the following error: $ No protocol specified invalid command name "bind" while executing "::unknown bind Text <Tab>" ("uplevel" body lin...
    Ingmar Delsink
    last modified by Ingmar Delsink
  • How to split M0 code in multicore project between external SDRAM and internal SRAM using linker scripts

    Hi All,      I'm working on device based on LPC4350 and use multicore M4F and M0 settings. I have external SPIFI where all firmware is stored (M0+M4) and external 16MB SDRAM. I was able to use l...
    Manlio Zanotti
    last modified by Manlio Zanotti
  • LPC1769 error reported

    Hi I was debugging a project of lpc1769 with lpcxpresso and show me the follow code error. Is the microcontroller dead? How can i fix it? Thanks
    Sebastian Barcia
    last modified by Sebastian Barcia
  • make: *** No rule to make target 'all'.  Stop. how to resolve this kind of error

    how to resolve this one anyone can explain ,make: *** No rule to make target 'all'
    manu kotyal
    last modified by manu kotyal
  • menu disabled in OS X after installation

    Hello, I installed LPCXpresso on OS X, but I can't activate it because all the menu items are disabled. I'm now using windows, but it would be nice if I can activate and use it on OS X. What can I do?  Thanks!
    Rian De Rous
    last modified by Rian De Rous