• How to update the LPCXpresso to the latest version available?

    Hello All,   I am using the LPCXpresso with the v8.1.4 released on March 2016. I could see that there is a newer version available as v8.2.2. I couldn't find any option to update to this latest version from th...
    Ramakrishnan Arumugam
    last modified by Ramakrishnan Arumugam
  • Debug code too large for license

    I appear to be experiencing the issue described here with LPCXpresso 8.2.2 on macOS Sierra 10.12.2. I completely reinstalled the program by deleting the LPCXpresso directory in /Applications/, /Users/Shared/NXPLPCXpre...
    Thomas Watson
    last modified by Thomas Watson
  • LPCXpresso Pro Flash size limited to 8K

    Hi,   I am using LPC Xpresso 8.1.4_606 with a Pro license installed. It used to work fine, all of a sudden its not allowing to flash more than 8K image size. I have tried debugging using FAQs, the csript works...
    Ram Gutta
    last modified by Ram Gutta
  • Error installing LPCXpresso 8.2.2 under Fedora 26

    Hello, I'm trying to install LPCXpresso 8.2.2 under fedora 26 but I get the following error: $ No protocol specified invalid command name "bind" while executing "::unknown bind Text <Tab>" ("uplevel" body lin...
    Ingmar Delsink
    last modified by Ingmar Delsink
  • No connection to emulator device?

    Hello, I am using the NHS 3152 on the Eval-board "NHS3152THADADK", which has 13 switches. I changed the blinky demo software to get an output at GPIO 5 and 7. The other Pins I wanted to use as Inputs, to see whether ...
    Raphael Prechtel
    last modified by Raphael Prechtel
  • The size of JN517x ZigBee 3.0 SDK is 0 byte

    Hi,dear all,    I would like to download the JN517x ZigBee 3.0 SDK(JN-SW-4270.zip) to install into LPCXpresso IDE on your official website. After download  is complete, the size of ...
    Sunny tan
    last modified by Sunny tan
  • LPCXpresso Activation Failure

    Actvation process for LPCXpresso V8.8.2 is not available.After generating serial number then the next page "https://lpcxpresso-activation.nxp.com/login_process.php " shows nothing.
    sar ang
    last modified by sar ang
  • can not access https://lpcxpresso-activation.nxp.com

    how to activate LPCXpresso Free Edition? after create the Serial number,i try to access https://lpcxpresso-activation.nxp.com,but failed,what is the reason? thanks i do it that: 1. Go to the menu en...
    yang pei
    last modified by yang pei
  • can not access https://lpcxpresso-activation.nxp.com

    i try to use different web ,but the result is the same,can not access https://lpcxpresso-activation.nxp.com ,and show nothing,can you tell me is any other way to activate LPCXpresso Free Edition ? thanks
    yang pei
    last modified by yang pei
  • Can not activate license

    Hello, I've been trying to activate the free license for two days but the activation site doesn't seem to work at all. Every time I try, I end up on this page: https://lpcxpresso-activation.nxp.com/login_p...
    Yann Martel
    last modified by Yann Martel
  • I want to use LPCXpresso IDE V8.2.2 bt it has some problem during activation process.After getting serial number the next page "https://lpcxpresso-activation.nxp.com/login_process.php" shows nothing,because of that activation key generation fails.What do

    LPCXpresso IDE Activation Fails 
    sar ang
    last modified by sar ang
  • LPCXpresso activation site not avilable

    I am using LPCXpresso V8.2.2 free version,during activation "https://lpcxpresso-activation.nxp.com/login_process.php" is not showing anything.Please help and thankyou very much
    sar ang
    last modified by sar ang
  • Can't add OpenOCD plugin to LPCXpresso IDE

    I've installed the LPCXpresso v8.2.2 IDE on Ubuntu 16.04 LTS and activated successfully, but I can't add the OpenOCD Debugging plugin to the IDE. I've tried writing the url in Help -> Install New Software... -...
    Lautaro Estienne
    last modified by Lautaro Estienne
  • My pro license has been locked...

    After W10 update, I was suddenly asked to (re) activated my license. Trying to reactivate the license, I got the following message: Then I chose OK, Enter the license activation code: then my password (checke...
    René Brunier
    last modified by René Brunier
  • LPCXpresso 54114_3 cores_blinky_example

    Hello to all,   I am working on the lpcxpresso 54114 development board. I have gone through different search options to get an idea about the effect of different cores on operating a piece of code. So, can any b...
    HIMANSHU DOSHI
    last modified by HIMANSHU DOSHI
  • Systick register, not showing in debug!!!

    Hello to all, From the piece of code:   /* Enable SysTick Timer */ SysTick_Config(SystemCoreClock / TICKRATE_HZ);   But, while debugging, can't see the register responsible for that. Do we need to enable...
    HIMANSHU DOSHI
    last modified by HIMANSHU DOSHI
  • Segmentation fault (core dumped) on Ubuntu 16.04 with lpcxpresso 8.2.2

    Hi, I can not run or launch My lpcxpresso 8.2.2. I already tried to reinstall the program and I also reinstalled my whole OS once. But the problem still occurs and I can not run the lpcxpresso and I got the foll...
    gergosnoo
    last modified by gergosnoo
  • LPCxpresso segmentation fault on startup on Ubuntu LTS

    # lpcxpresso Segmentation fault # uname -a Linux javox-linux-pc 4.4.0-81-generic #104-Ubuntu SMP Wed Jun 14 08:17:06 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux # cat /etc/issue Ubuntu 16.04.2 LTS \n \l # strace lpcx...
    Bernd Geiser
    last modified by Bernd Geiser
  • OSX: Flash image too large for this license.

    Whether I'm in the GUI or the CLI, I get "Flash image too large for this license." for something as simple as the FreeRTOS blinky example.   From here: /Applications/lpcxpresso_8.2.2_650/lpcxpresso/bin   I ...
    Jeffrey Chan
    last modified by Jeffrey Chan
  • Standalone MCU

    Hi; I am new to LPCXpresso and I am facing a problem. I programmed (simple blinky LED) my LPC4330 using LPC-Link2 debuger and it works fine. However, when I disconnect the JTAC ribbon cable the LPC4330 stop working. ...
    Sabah Nayyef
    last modified by Sabah Nayyef