• HTTPS Client with mbedTLS on K64F and mcuxpresso

    Hello, I'd like to run client https with mbedTLS, by using my k64f board and SDK examples - "liwp_httpssrv_mbedTLS_bm" Sth like How To: Secure e-mail client (SMTP + SSL) with KSDK1.3 + WolfSSL for FRDM-K64F....
    Bony X
    last modified by Bony X
  • Uart termios settings

    Hi,        I am running the uart dma_transfer example within KDS 2 on TWR-KL43Z. The example works fine when I use gtkterminal. I tried to emulate the same by sending a character 'A' 20 ...
    Tony Makkiel
    last modified by Tony Makkiel
  • KSDK GPIO driver with Processor Expert

    Open video

    Jorge_Gonzalez
    last modified by Jorge_Gonzalez
  • PRINTF %d doesn't handle negative numbers?

    It appears that PRINTF and related methods don't handle negative numbers:   #include "fsl_device_registers.h" #include "fsl_debug_console.h" #include "board.h" #include "pin_mux.h" #include "clock_config.h...
    Robert Poor
    last modified by Robert Poor
  • MMCAU in Keil uVision for K70

    Dear NXP/community support,   I'm trying to operate the K70's MMCAU in uVision IDE (MQX RTOS). I've downloaded the KSDK and got the MMCAU lib, but can't use these assembly files in uVision.   ha...
    Yaniv Bar on
    last modified by Yaniv Bar on
  • Using I2C with K64 and KSDK v2

    I am using the FDRM-K64F.   I'd like to write an app with MCUXpresso that does I2C communication with an external peripheral.   I thought I would start with the accelerometer, which is built-in and...
    Gabriel Grosskopf
    last modified by Gabriel Grosskopf
  • Hello, mpc5775be-416ds. Do you have a CD?

    Hello, mpc5775be-416ds. I have checked all the materials and found no CD in the objects attached to this development board. Excuse me, is there a CD in this development board?
    艳妹 李
    last modified by 艳妹 李
  • Run MQX 4.2 "Hello" Example on K66

    Hi,   I am trying to port the project to FRDMK66 with KDS 3.0 and MQX 4.2. I cloned the files from K65 and then made modifications on the linker and associated files referred to the porting guide and the porting...
    Charles Lin
    last modified by Charles Lin
  • No source available for "(gdb[1].proc[42000].threadGroup[i1],gdb[1].proc[42000].OSthread[1]).thread[1].frame[0]"

    I am working on FRDM-K64F board. I build the project and after debugging I get the following: No source available for "(gdb[1].proc[42000].threadGroup[i1],gdb[1].proc[42000].OSthread[1]).thread[1].frame[0]" No sourc...
    kirantujare
    last modified by kirantujare
  • Number conversion host to big endian

    Hi,   I'm working on MKE1xF family over SDK2.5 and I'm looking for a solution for endian to host converter like htons(). My problem is that if I had a number and I want to convert to little/big endian, what is...
    Jordi Becares
    last modified by Jordi Becares
  • MCU Bootloader for Frdm MKV31F

    Hey, I am trying to run an application(led_demo_a000) on on mkv31f board, but first I was wanting to run the bootloader. The steps I followed were similar to mentioned in MCU bootloader demo application.  Issue...
    sidhant singhal
    last modified by sidhant singhal
  • How do you detect (and handle!) a lwIP disconnection?

    My application handles graceful closing of the socket, but it does not recognize when the Ethernet cable has been disconnected.   In my packet-handling loop, I check the result of all netconn commands used, whic...
    dave408
    last modified by dave408
  • K21 UART4 RX with DMA problem

    Hi,   I meet a problem on UART4 Rx with DMA. I tried to modify and build driver_examples\uart\edma_transfer in KSDK2.0. The modifications as following: pin_mux.c CLOCK_EnableClock(kCLOCK_PortC); PORT_SetPinM...
    Jim Yang
    last modified by Jim Yang
  • Secure Bootloader AES help

    Hello! I would like to use on kinetis KV11Z and MK22FX the bootloader with security aes. When I try to compile, it asks me for the file aes_security.h and I can't find it. Can anyone help me? Is there a step by ste...
    Marco Bologna
    last modified by Marco Bologna
  • FreeRTOS LwIP SDK v2.0.0/V0.8.2 tpcipecho demo

    Dear all,   When implementing FreeRTOS lwip function on the basis of SDKV0.8.2 or V2.0.0 routines, we found that ehternetif.c file had no actual content, and compiled after changing #if 0 to #if 1, there were a ...
    李月鑫
    last modified by 李月鑫
  • How to enable debug_printfs within Kinetis Bootloader?

    I am running Kinetis Bootlader 1.2 on TWR-K65F180M. How do I enable the debug_printfs? The board is flashed over USB SDA. I tried defining DEBUG within KDS. But couldn't find corresponding outputs either in KDS consol...
    Tony Makkiel
    last modified by Tony Makkiel
  • dev_hid_generic_freertos_twrk65f180m with multiple end points

    I am trying to add end points to the usb example, dev_hid_generic_freertos_twrk65f180m. I added end points to the descriptor and indeed, the TWR-K65F180M enumerates, correctly for all of the end points. However, when ...
    Kirk Clendinning
    last modified by Kirk Clendinning
  • No Thread-Stack for KW21D in Kinetis SDK

    Hello,     in the manual for KW2xD ist says that the KW2xD's are capable of running the (Kinetis) Thread Stack. I'm using the KW21D256 but for this there is no example in the SDK for any connectivity. ...
    Sebastian Miethe
    last modified by Sebastian Miethe
  • Bug report: fsl_sai_edma ignores multichannel SAI module

    It appears that fsl_sai_edma.c uses the static s_edmaPrivateHandle to maintain callbacks for EDMA, but it reserves the 0 index for TX and 1 index for RX, ignoring SAI modules with more than one tx/rx channel...
    Jacob Jennings
    last modified by Jacob Jennings
  • Touch Sensing Software with the KSDK

    I am trying to install Touch Sensing Software to use with my KL16x project. The project is using KSDK 2.0. It seems the Touch Sensing Software will only install if you have KSDK 1.2, which I cannot seem to obtain. How...
    David Findlay
    last modified by David Findlay