• ke06z64 chip can not be downloaded KE06Z64芯片出现下载不了的问题

    求助:KE06Z64芯片出现下载不了的问题: Help: ke06z64 chip can not be downloaded Keil5通过J-Link将程序下载至电路板的KE06Z64芯片(4M外部晶振),弹出窗口提示Error:Flash Download failed - "Cortex-M0+"。 Keil5 downloads the program to ke06z64 chip (4m external...
    zhou jiangen
    last modified by zhou jiangen
  • Difference between (TOTALS) and .elf. Memory Usage Output

    Originally I thought that my .elf output for my memory represented the memory usage of my program. However, I found an option for TOTALS in my options menu... Not sure how I found it at this point but it's in there. N...
    cody hubman
    last modified by cody hubman
  • makefile:136: recipe for target 'HEXIWEAR_MK64.elf' failed

    Hi everyone,     I am new with KDS and I tried to use KDS to perform firmware changes on a IoT device, Hexwear, I have encountered the error of makefile:136: recipe for target 'HEXIWEAR_MK64.elf' faile...
    Frances Wong
    last modified by Frances Wong
  • How to relocate code in flash to a non-standard starting point?

    General question: What's the right way to relocate the code in a project so as to leave room in "low flash" for a flash-based bootloader?  And how do I tell KDS that the code has been relocated? Details:  I...
    Robert Poor
    last modified by Robert Poor
  • (Solved) Unable to program MK22FX512AVLQ12 controller

    Hi ,   I am using MK22FX512AVLQ12 controller in one of my product. I have made the development board for the same. But after assembly I am not able to programm the controller. i am using PE MICRO FX debugge...
    Gaurav More
    last modified by Gaurav More
  • K60 - How to init FTM and link it to PTA6 | PWN

    Hello, I have a problem with the whole FTM module and getting it running. After searching I could not find any working code example on how to activate the FTM0 module and link PTA6 to the module. Could anyone link ...
    dennis vymer
    last modified by dennis vymer
  • Energy metering TWR-KM34T75M

    Hello, I bought the TWR-KM34Z75M development kit. I would like to realize a 1 phase energy measurement with it.   However, it does not want to work. There are already problems building the project using the exam...
    Hurek Dariusz
    last modified by Hurek Dariusz
  • breakpoint - "No source file named"

    Hi There,   I have recently moved a project from an old hard drive to a new one.  I have been able to import this project into KDS and build no problems.  But, when I go to debug I get "No source file ...
    mjg8t
    last modified by mjg8t
  • USB Serial on frdm-k82f with Android

    Hello,   I am working on the frdm-k82f:to have a serial communication between board and Android device. But all the sample programs from the SDK I have tried was a failure.   The android device is ab...
    Ajayan Edayillam
    last modified by Ajayan Edayillam
  • Update fails

    When I check for updates, KDS 3.2 says there are a few updates to things like PEMicro debugger and FreeRTOS debugging plugin.  When I try to update, I get this:   An error occurred while collecting items to...
    David Sherman
    last modified by David Sherman
  • Kinetics design studio repository problem

    Ik krijg volgende foutmelding bij het zoeken naar updates en het installeren van new software in Kinetics Design Studio V3.2.0   No repository found at http://gnuarmeclipse.sourceforge.net/updates.   Ieman...
    kurt plaetevoet
    last modified by kurt plaetevoet
  • Not able to debug the code.

    Hello,   Currently, I am working on FRDM-KW36 development board. As per the BLE demo application user guide document I have uploaded the code of HRS(Heart Rate Sensor) on the development board. Then i checked it...
    Chintan Patel
    last modified by Chintan Patel
  • Which is recommended utility vs nanolibc for M0+

    I am planning to add assertions to my debugging tool capabilities.  Erich Styger has a couple of very helpful posts explaing how to get around the code bloat of stdio.h.  There are two different recommendati...
    KEVIN KRATZER
    last modified by KEVIN KRATZER
  • How to install and make USBDM programmer work in KDS 3.2

    Hello, pgo   I just bought a programmer running your USBDM from Luciano in Brazil.   Could you please explain me how to install USBDM plugin to make KDS 3.2 recognize USBDM programmer? I have carefully fol...
    Marco Aurelio P. Coelho
    last modified by Marco Aurelio P. Coelho
  • MCU bootloader Crc Check Option leads to to security breach

    Hello,   One question about mcu bootloader on MCU Xpresso V11.01 and KinetisFlashTools. Like i can see in the picture below it is possible to the mcu boot loader to launch an application whihout checking the cr...
    Didier JEANJEAN
    last modified by Didier JEANJEAN
  • Compile PE KDS project using ARM Compiler 6

    I have a c++17 project currently compiling with G++ 8.x, but I'm running out of flash memory. I've read that the ARM Compiler 6, used on Keil, is very effective on reducing the binary size, so I'm trying to migrate fr...
    Arthur Passos
    last modified by Arthur Passos
  • How to Maximize FLEXCAN Throughput?

    Hi everyone,   I'm trying to get the K20 series chip's CAN controller to have the highest throughput possible. I've configured my CAN 1 port at 500 kbps and am transmitting an extended (J1939) frame every 1...
    Brad Shelton
    last modified by Brad Shelton
  • Link m_text section to the D-FLash

    Hello, I am facing a problem that my code exceeds the plash size. Since the microcontroller that i am working with have a d-flash. Is it possible to specify for the linker to move the m_text section to the d-flash in...
    Haggui Souhail
    last modified by Haggui Souhail
  • WARNING: Failed to read memory @ address 0x00000000

    Hi,   I'm running k66 with MQX 4.02. I'm getting the warning randomly. When this happens the debugger is disconnected but the target keeps running and it appears it runs correctly. Any idea how to debug?  ...
    Ariela Blumer
    last modified by Ariela Blumer
  • KBOOT for KDS3.2.0 with SDK2.0

    Hello,I have to integrate a bootloader on a MK22FN512, For an important finished application developed on KDS3.2.0 with Eclipse and SDK 2.0 I want to load application firmware via UART0 interface. We bought 2500 parts...
    Didier JEANJEAN
    last modified by Didier JEANJEAN