• Update K82F EVB program using Win10

    Hello Team   I  used Win10   to  update the program of K82F board(as below plot) via OpenSDA following one  document as attached. I should use Win7, but I did 't  pay attention...
    Cindy Wen
    last modified by Cindy Wen
  • Preferred development system for FRDM-KE02Z?

    Hi,   I've recently got hold of a FRDM-KE02Z board (MKE02Z64VQH2) but I am struggling to get KDS set up to work with it. None of the SDKs 1.0.0-1.3.0 seem to support this board?   What is the recommended d...
    Toby Thain
    last modified by Toby Thain
  • Some problem about different batch of  MKL16

    When I burned same code of  low power mode,LLS0,into the the type of MCU, the current of mcu is not different. It took me a lot of time to find the problem.    I bought two different batch of the mcu,M...
    d h
    last modified by d h
  • MK20DN512 Clear i2c bus using Processor Expert InternalI2C Component

    I'm using an i2c eeprom memory and sometimes this memory lock the bus. The memory have no reset pin than, the only way to clear the bus is to send nine clock pulses and generate a stop condition to reset the i2c commu...
    César Daltoé Berci
    last modified by César Daltoé Berci
  • How to watch a memory location using watchpoint?

    I am using Kinetics Design Studio 2.0.0. I want to add a watch point on a memory location and I want to break when the value in the location becomes non-zero. I tried using a watchpoint with the following configuratio...
    Chaitanya Athalye
    last modified by Chaitanya Athalye
  • FRDM board and KDS - Debug Configurations no USB port appears

    Good afternoon,   There is no USB port for me to select on the Debugger tab in Debug Configurations. This problem occurred on Windows 10 and Ubuntu 19.10. I am using the Freedom KL25Z platform and the KDS 3.2....
    Rafael Azevedo
    last modified by Rafael Azevedo
  • USB Host MSD on K22FN1M0AM12 Not Receiving Response from Attached Device

    I have a custom board using K22FN1M0AM12 that I am trying to implement USB Host MSD on. I am using KDS v3.2.0 with Processor Expert v3.0.2. I am not using any RTOS. I used the example "USB_MSD_HOST_K60_PEx" as a start...
    Kevin Penn
    last modified by Kevin Penn
  • How to use Interrupts to send emergency signal Hexiwear

    Hi,    I am a fairly new programmer using KDS for my hexiwear. If have a question regarding interrupts and thresholds. I want to create an emergency function for the HR sensor, Accelerometer & Gyroscope...
    Mark Villamor
    last modified by Mark Villamor
  • Error during debugging for Hexiwear using KDS

    Good evening,   I am currently programming Hexiwear using KDS. I followed the startup instructions carefully and I did not encounter any problems building the program at gitub. I then moved on to debugging and i...
    Daniel Chen
    created by Daniel Chen
  • Memory problems with KDS 3.0 and K64

    Hi, I’m using Kinetis studio 3.0. which I think is wonderful IDE. However I have problem that I hope somebody could help me. In my project I have several arrays and the pretty big, between 1K to 8K of unint8_t a...
    Mike Smith
    last modified by Mike Smith
  • KDS update website link

    Hello, I develloped project into KDS few years ago. Since, I change My computer and reinstall KDS v3.2.   But Plugin for MQX not installated. Then I follow procedure said above, But error message appears: ...
    Daniel Chen
    created by Daniel Chen
  • HEX file larger than memory

    Hi, I built release configuration of MKL25Z4 freedom_bootloader in NXP_Kinetis_Bootloader_2_0_0. The only change I did was modification of linker script:   MEMORY { m_interrupts (RX) : ORIGIN = 0x000...
    Martin Dušek
    last modified by Martin Dušek
  • End On Injection (EOI)

    Good morning, Example of the registers that must be configured to detect the EOI (End Of Injection) and how it should be done.   Some explain
    Jorge Perez
    last modified by Jorge Perez
  • SPI SD Card interfacing without file system for MK20 using Kinetis Design Studio

    Hello,   I have been looking for an example code to interface to an SD card through SPI using a MK20 Kinetis microcontroller without using any file system (I do not need to use the card on a computer later, only...
    Pulsatrix P1
    last modified by Pulsatrix P1
  • ke06z64 chip can not be downloaded KE06Z64芯片出现下载不了的问题

    求助:KE06Z64芯片出现下载不了的问题: Help: ke06z64 chip can not be downloaded Keil5通过J-Link将程序下载至电路板的KE06Z64芯片(4M外部晶振),弹出窗口提示Error:Flash Download failed - "Cortex-M0+"。 Keil5 downloads the program to ke06z64 chip (4m external...
    zhou jiangen
    last modified by zhou jiangen
  • Difference between (TOTALS) and .elf. Memory Usage Output

    Originally I thought that my .elf output for my memory represented the memory usage of my program. However, I found an option for TOTALS in my options menu... Not sure how I found it at this point but it's in there. N...
    cody hubman
    last modified by cody hubman
  • makefile:136: recipe for target 'HEXIWEAR_MK64.elf' failed

    Hi everyone,     I am new with KDS and I tried to use KDS to perform firmware changes on a IoT device, Hexwear, I have encountered the error of makefile:136: recipe for target 'HEXIWEAR_MK64.elf' faile...
    Frances Wong
    last modified by Frances Wong
  • How to relocate code in flash to a non-standard starting point?

    General question: What's the right way to relocate the code in a project so as to leave room in "low flash" for a flash-based bootloader?  And how do I tell KDS that the code has been relocated? Details:  I...
    Robert Poor
    last modified by Robert Poor
  • (Solved) Unable to program MK22FX512AVLQ12 controller

    Hi ,   I am using MK22FX512AVLQ12 controller in one of my product. I have made the development board for the same. But after assembly I am not able to programm the controller. i am using PE MICRO FX debugge...
    Gaurav More
    last modified by Gaurav More
  • K60 - How to init FTM and link it to PTA6 | PWN

    Hello, I have a problem with the whole FTM module and getting it running. After searching I could not find any working code example on how to activate the FTM0 module and link PTA6 to the module. Could anyone link ...
    dennis vymer
    last modified by dennis vymer