• How to do FFT

    Hello sir How to do FFT in Arm processor
    TRYRTYRTY TRYNTRYRTYRTY
    last modified by TRYRTYRTY TRYNTRYRTYRTY
  • Failure in the NXP Website. Cant find page.

    Hi,   When I go in the page https://community.nxp.com/docs/DOC-103698 to bottom and click on Kinetis design studio page then I get an error that the page is not found.   Best regards, Osto
    Mehrdad Ostovary
    last modified by Mehrdad Ostovary
  • No Rule to Make Target error

    The error "No Rule to Make Target" is common when using build tools based on make, like Kinetis Design Studio (KDS), CodeWarrior 10, LPCXpresso, or S32 Design Studio.  While the error is not descriptive, and not ...
    Derek Snell
    last modified by Derek Snell
  • Debugger explodes on GPIO write

    I'm trying to debug a program I wrote for an MKL26Z MCU.  The MCU is on a custom PCB, in the CAL4 WLSCP package.  Debugging is happening using SWD, with SWDIO, SWCLK and reset connected.  SWDIO is pulle...
     Wolfe
    last modified by Wolfe
  • New project with USB CDC

    Hello, I already developed in the past application for Kinetis MCU using CodeWarrior first and KDS till today. Now I need to develop a new board and I think to skip to MCUXpresso IDE (with config tools and SDK builder...
    Gaspari Nicola
    last modified by Gaspari Nicola
  • Problem burning program to MCU in KDS

    hi! I want to burn to my MCU, bootloader + main program from KDS. I successfully burned my bootloader, but when i tried to burn the program, it failed ("J-Link GDB Server failed: Could not connect to ta...
    Matan Hasan
    last modified by Matan Hasan
  • problem with using Git on KDS

    I want to start using git on Kinetis. I cannot see git option in team in preferences.
    Ashkan Arvandi
    last modified by Ashkan Arvandi
  • Can't install Kinetis Design Studio(KDS) on Ubuntu 16.04 64-bit

    Hello, I want to install Kinetis Design Studio(KDS) IDE on Ubuntu 16.04 using the command given in section 2.3.2 of the link PDF_Link but i am getting error.i have attached screenshot of the error...
    Bhavin Maru
    last modified by Bhavin Maru
  • KDS with small toolbar

    Good morning   I installed the KDS on a 4K resolution display, and the icons on the tool bar are incredibly reduced, not for confortable using.   Is there a solution to make them bigger?   Thank You&...
    Pietro di Castri
    last modified by Pietro di Castri
  • How to set the serials clock configurations in running time using Processor Expert?

    I´m using KDS 3.0.0 and a S9KEAZ128AVLH MCU. I found the following methods that supposedly do this:   For  the AsynchroSerial component: SetBaudRateMode For I2C_LDD and CAN_LDD: SetClockConfiguration...
    Marcio L. Carleto
    last modified by Marcio L. Carleto
  • kl25z startup issue on Linux

    Hi,  I am developing a test software to test the interface with UART0 on the KL25Z board on the Linux Ubuntu 17.04 platform using the openOCD debug interface. I have been developing a data processing module usin...
    Brian Kelly
    last modified by Brian Kelly
  • Sorting out asm(); in KDS: How to change your compiler language to GNU ISO90

    Problems with asm(); calls in KDS coming back as "undefined reference"? as the FAQ says: KDS Frequently Asked Questions (FAQ) "By default the compiler settings are for C99, and there the 'asm' keyword is not recogniz...
    Rael Sasiak-Rushby
    last modified by Rael Sasiak-Rushby
  • Compiler Error with negative global variable shift parameter

    Compiler Error with negative global variable shift parameter Default Compiler using by  KDS 3.2.0 with FreeRTOS When shifting  like following Int32_t x ; Int32_t y = 8 ; Int8_t z = -1 ; x = y << z; o...
    Didier JEANJEAN
    last modified by Didier JEANJEAN
  • JTAG interface

    The above picture is the jatg interface in  TWR-KE18F.   The jlink_jtag interface (10 pin) is    They are different,  why?
    Li Feng
    last modified by Li Feng
  • uTasker V1.4.5 with integrated KDS support

    Hi All   I have made a new uTasker project release containing KDS project support. It is configured for the FRDM-K64F and KDS as default so imports, build, loads and runs directly.   Release notes and down...
    Mark Butcher
    last modified by Mark Butcher
  • Move CW10.5 K60 "Hello world" to KDS.

    I briefly describe the steps what I have done, maybe usefully for others. My KDS run time environment is Linux.   .Directly merge "Hello world" from CW10.5 to KDS based on K60.   1: Create new project bas...
    Tom Zheng
    last modified by Tom Zheng
  • Using USBDM with KDS (peripheral register view & debug)

    Hi All,   I have modified USBDM to better support KDS.   It now locates the KDS installation location during the USBDM installation and automatically installs the plugins The peripheral view is now usable...
    pgo
    last modified by pgo
  • KDS in CentOS

    So I decided to install KDS RPM version on a fresh Linux VM today and I have a few tips that might help.   You will need a x64 version of CentOS with 32 bit libraries. I don't think this is a great idea but mayb...
    williamely
    last modified by williamely
  • Possible Conflict Between KDS PE and RM

    I believe that I have found a conflict between the KDS PE error checking for component pin use and the Reference Manual for at least the K21 chip. In the RM for the K21 subfamily (Number: K21P121M120SF5RM attached), s...
    Joseph Gray
    last modified by Joseph Gray
  • [Problem Solved] can't connect to FRDM-K64F with KDS 1.1 on Ubuntu 12.04

    Hi, Posting this tip I just learned.   ORIGINAL PROBLEM I have the J-Link firmware (latest from Segger website) for OpenSDAv2 on FRDM-K64F. On Windows 7 I can connect to the board with KDS with the JLink debug...
    Maclain Lobdell
    last modified by Maclain Lobdell