• What do the words 8D and 94 on the variable capacitance diode model BBY40 mean.

    What do the words 8D and 94 on the variable capacitance diode model BBY40 mean. We have a unit that has an index of scanning fast lock code. According to the production feedback, some boards can't be scanned. There a...
    GuangYu Zhang
    last modified by GuangYu Zhang
  • I2C Block Register Address?

    I'm trying to get I2C working on the S32K144 using Simulink Toolbox but there's no input for a register address.  Can I edit the block to accept a register address in addition to the slave address?  Simulink...
    sparkee
    last modified by sparkee
  • NXP Simulink library for MPC5777C

    Hello,   I have been trying to use the CAN communication and ADC blocks with MBD_MPC574x_Config_Information block by selecting MPC5777C microprocessor but the CAN and ADC blocks shows the following err...
    Raman Nain
    last modified by Raman Nain
  • S32k144 pmsm kit

    dumitru-daniel.popa 1) I try to build push button controlled LED model using Simulink. code has been generated but there is an error which is shown below. it is showing access denied error.     ### Cre...
    Aniket Bagade
    last modified by Aniket Bagade
  • S12ZVM FOC MBD issue

    Dear Daniel: I have some questions want to ask you about S12ZVM FOC MBD control. I have run motor successful in EVB use the demo FTF-ACC-F1114_FOC_Sensorless.  My questions is 1: EVB use the 10mR resistance as...
    david meng
    last modified by david meng
  • problem for using AMMCLIB when generating code: can not find .tlc file

    when I use AMMCLIB in sumulink, simulating the model is fine, but when I build the model and generating code, following error is appeared:   S-function 'MLIB_Add_SF_F16' in 'untitled/MLIB_Add_F16/MLIB_Add_SF' sp...
    xiaobo zhang
    last modified by xiaobo zhang
  • Zigbee IOT gateway with FRDMKW41Z

    Hi Team,   I am working on Openthread Border Router (on linux Host) with FRDMKW41Z as radio. Now I want to implement Zigbee IOT gateway on the same Border Router Host(lets say RPI3B) with FRDMKW41Z as radio. I...
    Sudhamani Bijivemula
    last modified by Sudhamani Bijivemula
  • How to minimize code generation into Interrupt Handler

    Hello NXP MBD Community,   I've recently figured out that in case of using CTU for triggering Subsystem (over Trigger Port, function-call) and the following Sybsystems in the chain, the generated code for t...
    Sergey Suyakov
    last modified by Sergey Suyakov
  • S12ZVC任务执行周期不对

    我参考下面的链接 (How-to) Multitasking on S32K144 MBDT Simulink  制作了一个模型,应该是每1秒反转一次,但是在板子上表现为大约2秒反转一次。我不知道是什么原因。 我使用的板子: DEVKIT-S12ZVC development platform for S12ZVC | NXP  模型见附件
    张 三
    last modified by 张 三
  • MATLAB Toolchain to program MPC5744P Custom Hardware

    Hello, I am designing a custom hardware(MPC5744P) compliance with MATLAB Target Hardware. I bought a DEVKIT-MPC5744P. Thanks to On-Board Debugger(OpenSDA), I am able to directly program DEVKIT-MPC5744P from...
    Samet Can Biçer
    last modified by Samet Can Biçer
  • I installed model based design toolbox 3.1.0 but that didn't installed any compiler. So I installed it by myself but I am getting a hard time in setting it up which is explained on page 9 of the Quick start guide of "Model-Based Design Toolbox MPC57xx Ser

    I installed model-based design toolbox 3.1.0 but that didn't installed any compiler. So I installed it by myself but I am getting a hard time setting it up which is explained on page 9 of the Quickstart guide of the "...
    Raman Nain
    last modified by Raman Nain
  • Need Boot loader software for S32K144EVB

    Hello NXP team We are need S32K144EVB Boot loader software. will you please upload it
    Satven Mechatronics
    last modified by Satven Mechatronics
  • S32K144EVB/Generated code download issue

    Hi NXP MBDT team,   I tried several times to generate the code of a basic example "gpio_s32k144.mdl" and download it to the board without success (the code is well generated but the download process did not acco...
    MOHAMED BENDERRADJI
    last modified by MOHAMED BENDERRADJI
  • MPC5744p RevE MBD flash problem

    Hi NXP team and fellow members,   I have recently ordered MPC5744P DevKit and received the Rev E DevKit. I tried to compile and download the code from Simulink model-based toolbox example by following the quick s...
    SHAO Jianbo
    last modified by SHAO Jianbo
  • S32K144EVB / issue when generated code exported to S32 DS IDE

    Hi NXP MBDT,  I have exported the generated code of " PMSM_ClosedLoop_s32k144.mdl" to S32 DS IDE. However, when i try to compile the code i have the following errors:  Please help me to resolve this issu...
    MOHAMED BENDERRADJI
    last modified by MOHAMED BENDERRADJI
  • Software from NXP

    dumitru-daniel.popa  I have purchased MTRDEVKSPNK144 from NXP for Rapid prototyping of my control algorithm. I just wants to ask 1) weather all software tool like freemaster,MCAT and Model based design toolboxa...
    Aniket Bagade
    last modified by Aniket Bagade
  • Module 1: Environment Setup

    INTRODUCTION In this module of the 3-Phase PMSM Workshop, the focus is on the hardware and software setups that are going to be used throughout this workshop to implement and test a complete 3-phase Permanent Mag...
    dumitru-daniel.popa
    last modified by dumitru-daniel.popa
  • How to use LPUART_Receive block ?

    Hi, while using LPUART_Receive driver block (latest S32K1x MBD toolbox with patches in R2019b): is there any way to be sure (or check) if the block execution did indeed initiate reception ? I'm asking because...
    Maciek
    last modified by Maciek
  • How to send multiple CAN messages after stop and restart the CAN analyzer  in the model attached

    RHinnen Hi , RHinnen    Could  you spare some precious time to help me solve the following problems: How to  modify the model attached to send multiple CAN messages and keep sending CAN messa...
    hm Chen
    last modified by hm Chen
  • How to enable the software watchdog timer (SWT) properly - MBD toolbox - MPC5744P?

    Hello,   I am using the Devkit MPC5744P and the Model Based Design Toolbox 3.0.0.   I am trying to use the SWT, but aparently the device is not recovering after going to the reset state. First I initialize t...
    Rafael Castro Barbosa
    last modified by Rafael Castro Barbosa