• UART not working after IAP

    Hello everyone,   I managed to successfully reinvoke ISP with LPC11U24 using IAP 57 command. I can read the device signature and flash new code using Flash Magic through UART interface. However, when I...
    jloncar
    last modified by jloncar
  • Is safe lpc11u24 WriteEP simultaniously?

    Hi, I I read UM10462 but not found answer.   case1 Is safe lpc11u24 WriteEP simultaniously into different endpoint ?   { uint8_t tmpTxBuf[64]; pUsbApi->hw->WriteEP(pUsbHandle, 84, tmpTxBuf, 64);...
    Darius Babrauskas
    last modified by Darius Babrauskas
  • LPC11c24 LPC open example CAN not receiving messages

    Dear community,   I am testing two LPC11c24 evaluation boards CAN BUS. To do so, I have connected the units CAN_H,CAN_L, powered VCC and loaded the LPCopen CAN example on both boards. In the loaded LPCOpen exa...
    mat ric
    last modified by mat ric
  • Suggest to add reading function for ISER on LPCOpen

    Hi,   According to user manual of LPC11U6X and this post LPC11 - interrupts during IAP , SW needs to temporarily disable interrupt before using IAP calls. My idea is to (1) backup ISER0 (2) write ...
    Jeremy Hsiao
    last modified by Jeremy Hsiao
  • A possible defect of Chip_ADC_SetClockRate()

    Hi,   I'm writing to report possible defect of Chip_ADC_SetClockRate() in the LPCOpen 3.03. The content of this function is as below:       Chip_ADC_SetDivider(pADC, ((Chip_Clock_GetSystemCl...
    Jeremy Hsiao
    last modified by Jeremy Hsiao
  • LPC11C24 I2C troubles

    Hello to all, I am using LPC11C24 for a project that requires me to implement I2C communication between the board (LPCXpresso LPC11C24 Rev B) and some sensors using I2C protocol. I looked at the example code provided...
    Federico Fiorini
    last modified by Federico Fiorini
  • LPC11u12 USART inverted bits

    Hi everyone ! How can I config usart on lpc11u12 to send/recieve inverted order of bits? I didn't see anything in any register. Thanks
    Anton Rudomanenko
    last modified by Anton Rudomanenko
  • Stuck in IntDefaultHandler after Wakeup

    Hello all, I'm working on a project using the LCPXpresso LPC11C24 Board Rev B with LPC-Link and I need to implement Deep Sleep mode for low power consumption usage. I'm also using MCUXpresso 10.2.1. I followed ...
    Federico Fiorini
    last modified by Federico Fiorini
  • DMA LPC11u12

    Hi everyone! Is it DMA support on lpc11u12? It is not clear from user manual
    Anton Rudomanenko
    last modified by Anton Rudomanenko
  • Debugger probe problem LPC11U68

    I am using LPC11U68 eval board to program and debug a off board target processor (LPC11U68). The debug session does not start and I get the following errors: MCUXpresso IDE RedlinkMulti Driver v10.2 (Jul 25 201...
    Mohamed Shaheen
    last modified by Mohamed Shaheen
  • Problem with LED blinking LPC11e14

    Content originally posted in LPCWare by drvrh on Thu Aug 20 03:05:34 MST 2015 Hello, I have a problem with LED blinking and my LPC11e14, programming it's OK but on my ouput pin have nothing. On all IO pin have voltag...
    lpcware
    last modified by lpcware
  • LPC1549 and LPC11U68 Failed on connect: Ee(42). Could not connect to core.

    Hi,   On a fresh Windows 10 setup, running MCUXpresso IDE v10.2.1 [Build 795] I cannot debug my LPCXpresso V2 boards LPC11U68 or LPC1549. Both Debug Probes show up fine as LPC-LINK2 CMSIS-DAP V5.183 with no driv...
    Adam Himer
    last modified by Adam Himer
  • I2C leakage current at high temperatures

    Hi    I have a LPC11E14 using it over I2C as a slave.    Now when the micro controller is not powered, I can see a leakage current on the I2C pins PDIO0_4/SCL and PDIO_5/SDA into the control...
    edos
    last modified by edos
  • DMX512 Slave SDK not working

    Hello,   I´ve being trying to use the source code and schematic provided by NXP in the AN11153 (DMX/RDM slave) but I can´t seem to make it work. I´m using a LPC1112/102, and I tried compiling ...
    Thiago rodrigues
    last modified by Thiago rodrigues
  • Can't connect to LPC11A04UK

    Hi,   I've tried to communicate to the LPC11A04UK (WLCSP20 package) without success. I'm using the LPC-Link-2 CMSIS-DAP V5.173   I get the following error message :    --------------------------...
    Louis-Philippe Dion
    last modified by Louis-Philippe Dion
  • Register values in UART

    Hi! I am using LPC11uxx and trying to configurate UART smart card mode. When I filled register DLM value, IER also fiiled by the same value? Is it normal? If yes, why it is happens? 
    Anton Rudomanenko
    last modified by Anton Rudomanenko
  • UART smart card mode

    Hello! I'm try to implement connection between LPC11u12 and smart card via UART. To provide the right clock to the smart card I should to fill UART DLL and DLM registers this way: uint32_t divider = ((( sys_clk / ((sc...
    Anton Rudomanenko
    last modified by Anton Rudomanenko
  • Where have the IOH libraries gone for the LPC11U37H?

    Hi,   I've got some very old IOH libraries for the 11U37 and was just looking to see if they'd been updated since 2013 but they seem to have disappeared.  Any idea where the libraries and documentation have...
    Shareef Jalloq
    last modified by Shareef Jalloq
  • Timer LPC11uxx

    Hi! Can anybody help me to config the 32-bit timer to catch 3 * 10^(-6) seconds? I did smth like that: if my freq equal to 48MHz, then every 154 ticks has passed 3 nsec. Using that idea, I avoid of configure prescaler...
    Anton Rudomanenko
    last modified by Anton Rudomanenko
  • LPC1114 bypassing the system oscillator

    I have a question regarding bypassing the system oscillator in LPC1114. If I enable the system oscillator bypass enable (set bit 0 of SYSOSCCTRL to be 1), I could connect an external clock source to XTALIN pin as the ...
    Haohao Liao
    last modified by Haohao Liao