• imx8mq load fimware to m4 from linux

    Hi. I am trying to use the M4 core from linux in an IMX8MQ processor. I tried the m4fwloader but it says: "Board is not supported.". Then I tried m4ctrl, but after the "insmod m4ctrl_dev.ko" step, I ...
    Ioannis Gragopoulos
    last modified by Ioannis Gragopoulos
  • Help loading and running bin file via JLink

    Hello,   I am having difficulty running the ddr-test-uboot-jtag-mx6dq.bin on my custom board with 4 MT41K256M16HA-125 chips ganged off 1 CS line and each connected to 16bits of the DDR Data bus. I am using ...
    Matthew Nunez
    last modified by Matthew Nunez
  • i.MX53, Linux 4.9 and Etnaviv

    We have i.MX53 based custom HW and so far we have been using 2.6 - series kernel since that was the last officially supported one.   I noticed that that Yocto 2.2 have support for i.MX53 and kernel 4.9 has the E...
    mc maddie
    last modified by mc maddie
  • Boost output of PMIC PF0100

    Hi Team  We  are using boost  output of PMIC to power HDMI and USB mass storage device, By  default when we are turning on device we are getting 5V but  after 11 sec boost output voltage beco...
    Abhishek singh
    last modified by Abhishek singh
  • PF3000 LICELL pin connection options

    I find the following passage in the PF3000 Rev. 9 datasheet:   6.3.11.3 Coin cell battery backup The LICELL pin provides for a connection of a coin cell backup battery or a “super” capacitor. If th...
    Yevgeniy Maksimenko
    last modified by Yevgeniy Maksimenko
  • Looking for sample code in using rpmsg_multiept for iMX7D

    Can you anyone please guide me through using the rpmsg_multiept for iMX7D. I have tried insmod rpmsg_multiept.ko, but does not seemed to create /dev/rpmsg_xxx Any guidance is very much appreciated. Thank you very m...
    Roger Lumo
    last modified by Roger Lumo
  • Main adapter for imx8 nano evk

    Today I received an IMX8 nano evk. It is equiped with an 110V main adapter. Can I use a standard notebook USB-C 220V main adaptert with 44W for the evk?   Thanks   Jan
    Jan Michaels
    last modified by Jan Michaels
  • DDR stress test cause system hang in Linux

    Hello NXPs, Release: Yocto-Sumo (4.14.98_2.0.0_GA) Board: i.MX8MQ EVK based custom board We're working on iMX8MQ based custom-designed board with 2GB DDR4 RAM (MCIMX8M-EVK 3GB LPDDR4 RAM) now we're having an issue whe...
    John Coll
    last modified by John Coll
  • This is a question about the wifi / bt module information available in imx8qm mek.

    Hello. I would like to ask about the wifi / bt module. Is there a list of wifi / bt modules available for imx8qm? please answer about my question. Thank you.
    sujin kim
    last modified by sujin kim
  • XHCI: USB transaction errors causes instability

    Hi,   I would like some advice on a USB issue that we are struggling with. We are using BSP 4.19.35.   The modem that is connected to the i.MX8qxp via a usb hub sometimes misbehaves and we see 'USB transac...
    Jonas Karlsson
    last modified by Jonas Karlsson
  • I need optee_os support for Maaxboard in yocto project, any help?

    I have successful built yocto project image with the maaxboard company's kernel and u-boot code at here: https://www.element14.com/community/message/288659/l/re-how-can-i-build-an-image-for-the-maaxboard-myself#2...
    peter zhang
    last modified by peter zhang
  • git.freescale.com down

    We noticed this morning our builds started failing. Looks like attempting to clone firmware-imx is failing.   When I try to clone the repo independent of a yocto build I see the following output:   git clo...
    Adam Bader
    last modified by Adam Bader
  • Is git://git.freescale.com down? fetch error

    After below commands $ DISTRO=fsl-imx-wayland MACHINE=imx8mqevk source fsl-setup-release.sh -b build-wayland $: bitbake fsl-image-qt5-validation-imx  Getting error@Git.freescale.com  Carlos_Musich ERROR...
    Rajath Kumar Divakar
    last modified by Rajath Kumar Divakar
  • error:/dev/video0 format not supported

    executing 'capturing' in SV3D-project on imx8qxp-mek,the UART output is "/dev/video0 format not supported" but input cmd like"gst-launch-1.0 v4l2src device=/dev/video0 ! 'video/x-raw,width=1920,height=1080,framerate=...
    peterson hou
    last modified by peterson hou
  • i.MX6. RMII + RGMII.

    Hi,   1. Does it possible to make it work 2 ethernet ports ( RMII + RGMII) at the same time on i.MX6?. Now we only use RMII (CLK on GPIO16).   2. Is it supported by mainline or non-mainline Linux kernels?...
    EgleTeam
    last modified by EgleTeam
  • Bug-Fixes for FlexSPI

    We are using a SoM with an i.MX8M-Mini and tried to use the FlexSPI to communicate with an FPGA which simulates a flash memory using 1-1-4 or 1-4-4 transfer mode. To get that working we had to fix or extend the linux...
    Christoph Fink
    last modified by Christoph Fink
  • access MIPI from both A53 and M4

    Dear person in charge,   I have one question about MIPI on i.MX 8M Mini. Is it possible to access to MIPI from both Cortex-A53 and Cortex-M4?   best regards, Shu
    野田 周作
    last modified by 野田 周作
  • setting procedure of function allocation on each cores

    Dear Person in charge,   Now, we're developing our product based on i.MX 8M Mini (Linux on Cortex-A53 and RTOS on Cortex-M4) as bellow. - MIPI-DSI ( display indication ) on Cortex-A53 side - MIPI-CSI ( for cam...
    野田 周作
    last modified by 野田 周作
  • imx8-yocto如何安装本地编译器

    请问如何在yocto上安装本地arm编译器?4.14-sumo是用在X86_64 PC平台上的,它能用在IMX8平台上么? 我们的目的是想在IMX8设备内集成编译环境,可以在IMX8设备里编译库文件及应用之类的。
    yougang hu
    last modified by yougang hu
  • Display pixel clock limitation to 74.25 MHz

    Hi,   I'm using a board with the IMX8 SoC and 4.14.98 IMX kernel.   I'm trying to add support for a MIPI-DSI display (800x480@60Hz) that needs a pixel clock of ~25MHz.   The problem is that there is ...
    Sebastian Panceac
    last modified by Sebastian Panceac