• imx6 libsensors TmpSensor.cpp

    android/hardware/imx/libsensors路径,TmpSensor.cpp文件 TmpSensor::readEvents(),这个函数,获取事件的频率很慢,可以怎么解决? 器件ic,驱动上报的频率是50hz,请问hal里面,怎么才可以更快的获取数据?
    卫 陈
    last modified by 卫 陈
  • imx6solosabresd do_image_wic failed

    您好,我在ubuntu18.04环境中,LF_L5.4.3_1.0.0生成针对imx6solo的 image,uboot等,但是最后阶段报错误,无法生成u-boot.imx,最后也无法生成需要的image等文件,不知道是什么原因,谢谢。   DISTRO=fsl-imx-fb MACHINE=imx6solosabresd source imx-setup-release.sh -b buildminimal echo...
    JIANFENG SONG
    last modified by JIANFENG SONG
  • PMIC for iMX8MQ

    Hi Team,   We are going to use iMX8M Quad Lite processor in our application. We are going to use 2x same processors in our application. So can we use one common PMIC between 2x processors, if it suffices our cur...
    Sahil Nayak
    last modified by Sahil Nayak
  • Porting G2D to custom OS: where is G2D repository for i.MX7ULP ?

    Hi all,     As we plan to port in-house kernel to i.MX7ULP to support 2D only applications, we would like to port G2D infrastructure. Section 2.4 "Support of new operating system in G2D" of document "i.MX ...
    ko-hey
    last modified by ko-hey
  • compile error u-boot-fw-utils under yocto zeus

    I am trying to compile the u-boot-fw-utils under yocto zeus. Earlier i was getting compilation error but somehow imanages to replace my config with mx6sxsabresd_optee_defconfig as defined in default configuration...
    Nikhil sahu
    last modified by Nikhil sahu
  • how to use imx8qm hdmi rx function in android10?

    HI :   Does anyone has experiment of using imx8qm's hdmi rx function. I have tried it with fsl-imx8qm-mek-hdmi-in.dts , and using it as a camera , but fail. The hardware is good: [ 505.934931] HDMI RX Cab...
    jiang yaqiang
    last modified by jiang yaqiang
  • build apt-get  code in yocto image failed in maaxboard  board

    hi, I want to build apt-get  in my yocto image in maaxboard  which is porting  from imx8  imx8mqevk board , so I can install executable code from board.  I add some lines in my loc...
    peter zhang
    last modified by peter zhang
  • Why two codec drivers in iMX7ULP

    Hello,   I was going through audio codec flow in iMX7ULP and i could see, there are two drivers which are controlling the wm8960 codec in the iMX7ULP eval board:   In the M4 SDK, components/codec/wm8960/fs...
    jai ganesh sridharan
    last modified by jai ganesh sridharan
  • iMX8MQ processor Socket Based EVK for secure boot (OTP)

    Hi,   We are planning to work for a secure Boot on iMX8MQ. For secure boot, we need to program the fuses on i.MX8MQ(processor) and as per our understanding this is a one-time programmable process. So in the de...
    Nilesh Patel
    last modified by Nilesh Patel
  • compile error in kernel 5.4

    Hi guys,   I have using standlone kernel build in kernel 5.4, but when i am building 5.4 in standalone mode, there is always compile error below: scripts/extract-cert.c:21:25: fatal error: openssl/bio.h: Could...
    Yibeom Han
    last modified by Yibeom Han
  • How to config MIPI DSI clock and data rate on imx8mq?

    hi all: Now we are porting a 5" LCM on imx8mq playform with LCDIF. we got panel timing data as below, and vendor stated that is base on mipi bit rate 540MHz display-timings {      ...
    CS Lin
    last modified by CS Lin
  • imx6ull使用bitbake fsl-image-qt5构建yocto出现问题

    在使用imx6ull在线构建yocto时出现如下问题,不知道什么原因?谢谢!   ERROR: cpuburn-neon-20140626-r0 do_fetch: Fetcher failure: Fetch command failed with exit code 4, output: failed: Connection refused. failed: Connection refused. ERROR: ...
    hy xu
    last modified by hy xu
  • Video size is only 595

    Hi,  I'm using FLEX-iMX8MM with Yocto image. I tried to record video with gstreamer framework but after recording. Video size is only 595. Note that while recording, no any error or warning occur.  This is...
    toanjunifer@gmail.com
    last modified by toanjunifer@gmail.com
  • Want old design data for i.MX6Q-SDB

    Hi all, I am using i.MX6Q to check S/W operation for my customer. Unfortunately I have only an old revision (SCH-27516 Rev.B3) board in my hand. Please provide design data for this revision to someone.   BR, ...
    George Fukutomi
    last modified by George Fukutomi
  • For UART DMA hardware flow control (CTS\RTS additional wires) should be applied.

    HI Muhin It seems I see the issue also. Could you show more details?   Thanks BR
    Hongxing Yu
    last modified by Hongxing Yu
  • imx6sx: uart6 and rpmsg issue

    Hi all,   i am on a simple busybox-based  rootfs, 4.14 imx-2.0.0 kernel, and observing a strange issue:   by a simple bash script, i am performing a simple read / write test from uart2 to uart6, and j...
    Angelo Dureghello
    last modified by Angelo Dureghello
  • How to swap UART5 TX/RX in imx6

    I use CSI0_DAT14 and CSI0_DAT15 for UART5 ,  on default , CSI0_DAT14 = UART5_RX  and CSI0_DAT15 = UART5_TX, But I want to swap them, so in my dts file i change as following: pinctrl_ua...
    Jerry Yan
    last modified by Jerry Yan
  • qca6174 driver problem after enabling docker associate kernel options.

    Hi:    I've ported ubuntu18.04 on i.mx8mq-evk, and enabled the docker by modifying the kernel options.       But, for now, on this platform(ubuntu with docker), I can not insm...
    downey downey
    last modified by downey downey
  • too fast playback speed of video, recorded by gstreamer on i.mx6

    Hello. Is it possible to record framebuffer on imx.6 via gstreamer ? I've tried to use multifilesrc, but something went wrong.   For test I used command: while [ true ] ; echo `date` > /dev/tty0 ; slee...
    Eugene Kruglikov
    last modified by Eugene Kruglikov
  • Ethernet not working in iMX6UL EVK

    I built Yocto project for iMX 6UL EVK from imx-4.19.35-1.1.0.xml - imx-manifest - i.MX Release Manifest  and unable to get Ethernet on this build. root@imx6ulevk:~# ifconfig lo Link encap:Local Loopback i...
    Kanimozhi Thangappan
    last modified by Kanimozhi Thangappan