• compile error in kernel 5.4

    Hi guys,   I have using standlone kernel build in kernel 5.4, but when i am building 5.4 in standalone mode, there is always compile error below: scripts/extract-cert.c:21:25: fatal error: openssl/bio.h: Could...
    Yibeom Han
    last modified by Yibeom Han
  • How to config MIPI DSI clock and data rate on imx8mq?

    hi all: Now we are porting a 5" LCM on imx8mq playform with LCDIF. we got panel timing data as below, and vendor stated that is base on mipi bit rate 540MHz display-timings {      ...
    CS Lin
    last modified by CS Lin
  • imx6solosabresd do_image_wic failed

    您好,我在ubuntu18.04环境中,LF_L5.4.3_1.0.0生成针对imx6solo的 image,uboot等,但是最后阶段报错误,无法生成u-boot.imx,最后也无法生成需要的image等文件,不知道是什么原因,谢谢。   DISTRO=fsl-imx-fb MACHINE=imx6solosabresd source imx-setup-release.sh -b buildminimal echo...
    last modified by JIANFENG SONG
  • imx6ull使用bitbake fsl-image-qt5构建yocto出现问题

    在使用imx6ull在线构建yocto时出现如下问题,不知道什么原因?谢谢!   ERROR: cpuburn-neon-20140626-r0 do_fetch: Fetcher failure: Fetch command failed with exit code 4, output: failed: Connection refused. failed: Connection refused. ERROR: ...
    hy xu
    last modified by hy xu
  • Video size is only 595

    Hi,  I'm using FLEX-iMX8MM with Yocto image. I tried to record video with gstreamer framework but after recording. Video size is only 595. Note that while recording, no any error or warning occur.  This is...
    last modified by toanjunifer@gmail.com
  • Why two codec drivers in iMX7ULP

    Hello,   I was going through audio codec flow in iMX7ULP and i could see, there are two drivers which are controlling the wm8960 codec in the iMX7ULP eval board:   In the M4 SDK, components/codec/wm8960/fs...
    jai ganesh sridharan
    last modified by jai ganesh sridharan
  • Want old design data for i.MX6Q-SDB

    Hi all, I am using i.MX6Q to check S/W operation for my customer. Unfortunately I have only an old revision (SCH-27516 Rev.B3) board in my hand. Please provide design data for this revision to someone.   BR, ...
    George Fukutomi
    last modified by George Fukutomi
  • For UART DMA hardware flow control (CTS\RTS additional wires) should be applied.

    HI Muhin It seems I see the issue also. Could you show more details?   Thanks BR
    Hongxing Yu
    last modified by Hongxing Yu
  • imx6sx: uart6 and rpmsg issue

    Hi all,   i am on a simple busybox-based  rootfs, 4.14 imx-2.0.0 kernel, and observing a strange issue:   by a simple bash script, i am performing a simple read / write test from uart2 to uart6, and j...
    Angelo Dureghello
    last modified by Angelo Dureghello
  • iMX8MQ processor Socket Based EVK for secure boot (OTP)

    Hi,   We are planning to work for a secure Boot on iMX8MQ. For secure boot, we need to program the fuses on i.MX8MQ(processor) and as per our understanding this is a one-time programmable process. So in the de...
    Nilesh Patel
    last modified by Nilesh Patel
  • How to swap UART5 TX/RX in imx6

    I use CSI0_DAT14 and CSI0_DAT15 for UART5 ,  on default , CSI0_DAT14 = UART5_RX  and CSI0_DAT15 = UART5_TX, But I want to swap them, so in my dts file i change as following: pinctrl_ua...
    Jerry Yan
    last modified by Jerry Yan
  • qca6174 driver problem after enabling docker associate kernel options.

    Hi:    I've ported ubuntu18.04 on i.mx8mq-evk, and enabled the docker by modifying the kernel options.       But, for now, on this platform(ubuntu with docker), I can not insm...
    downey downey
    last modified by downey downey
  • too fast playback speed of video, recorded by gstreamer on i.mx6

    Hello. Is it possible to record framebuffer on imx.6 via gstreamer ? I've tried to use multifilesrc, but something went wrong.   For test I used command: while [ true ] ; echo `date` > /dev/tty0 ; slee...
    Eugene Kruglikov
    last modified by Eugene Kruglikov
  • Ethernet not working in iMX6UL EVK

    I built Yocto project for iMX 6UL EVK from imx-4.19.35-1.1.0.xml - imx-manifest - i.MX Release Manifest  and unable to get Ethernet on this build. root@imx6ulevk:~# ifconfig lo Link encap:Local Loopback i...
    Kanimozhi Thangappan
    last modified by Kanimozhi Thangappan
  • console log do not output after uart cable plug out and re-connect

    Dear Nxp       i use the imx6solo and  run the linux , the kernel is 4.14.78.       the ttymxc0 is the debug port, i pass the parameter "console=ttymx...
    Vecio Lin
    last modified by Vecio Lin
  • Max RAM can be used from M4 in IMX7ULP

    Hello,   I am trying to find how much max memory can be used in Cortex M4 of IMX7ULP in Low power mode.   As I see from the ref manual, it seems that max 256KB can be used from internal RAM.  Ca...
    Vivek Rajpara
    last modified by Vivek Rajpara
  • i.MX8QM with EDP Panel

    我现在需要调试IMX8QM EDP 屏幕,但是没有找到EDP 屏幕对应的AUX 信号,我要读正确的EDID的话是要去接HDMI 的AUX 还是DDC呢?
    George Li
    last modified by George Li
  • NULL pointer deref in sdma_int_handler (sabreboard i.MX7D)

    Hello everyone! When the mikrobus on Sabreboard with i.MX7D is used as a UART, and RX and TX are connected with acable (see https://photos.app.goo.gl/kbtempE6Us5vtatSA, red and white cable are interconnected), then t...
    Christina Quast
    last modified by Christina Quast
  • iMX8MQ got stuck during booting rootfs

    Hi,    I'm tring to use NFS to mount rootfs at iMX8MQEVK. The images used could boot from emmc normally. When I downloaded the image & dtb by DHCP and mounted the rootfs using NFS, the boot log showed t...
    Ida J
    last modified by Ida J
  • Opencv on i.MX8 Yocto

    Hello,   About i.MX8 Yocto,does the Opencv in aarch64-mx8-poky-linux will upgrade? Now we use i.MX8 QM 2.3.0 Yocto release the OpenCV version is 4.0.1,we want OpenCV version 4.1.2 does it will upgrade or ...
    Xu Ji
    last modified by Xu Ji