• android_Q10.0.0_2.0.0 SPL cannot load ATF startup

    If the DEBUG serial port is UART2 according to your own platform, SPL cannot load ATF and stops at the following log。the same problem occurs with EVK development boards.Attached is the modified patch。 Help to analyze...
    Aber fu
    last modified by Aber fu
  • SDHCI trap with register dump dropping SDIO clock

    iMX8MM dropping SDIO clock to 12MHz causes the SDHCI crash   [  641.123790] mmc0: sdhci: ============ SDHCI REGISTER DUMP ===========[  641.130232] mmc0: sdhci: Sys addr:  0x54968d04 | Version:...
    vikramramanna
    last modified by vikramramanna
  • Is Yocto Zeus 5.4.3_1.0.0 GA for i.MX8M Mini and NANO

    Hi, According to release notes https://www.nxp.com/docs/en/release-note/IMX_LINUX_RELEASE_NOTES.pdf  Yocto Zeus 5.4.3_1.0.0 is a GA quality release for i.MX8M Mini and Nano. For some reason binary Demo images fo...
    Felix Radensky
    last modified by Felix Radensky
  • Gstreamer dropping frames (opencv videocapture)

    I am using opencv to get fames from the CSI camera module on the IMX8M-mini dev kit. however every third frame is being dropped. Diging into the issue the issue is coming from the gstreamer backend and generates the f...
    Tyler Ward
    last modified by Tyler Ward
  • 8MMINILPD4-EVK Hangs with clean Kernel

    Hi,    I'm trying to build my own kernel to use with 8MMINILPD4-EVK, but the board doesn't boot.   Steps I'm using: Set the board to download mode and flash  L4.14.98_2.0.0_ga_images_MX8MME...
    Lucas Alves
    last modified by Lucas Alves
  • How to setup Sai5 to be 50%/50% Duty Cycle on Frame clock

    Hi,    I'm using Sai5 in master mode. So Sai5 provides Bit and Frame clock. But If I record more than 2 channels in I2S mode, the Frame clock is a pulse, not 50% down/ 50% up.   How Can I configure S...
    Lucas Alves
    last modified by Lucas Alves
  • Difference uboot-fslc <-> uboot-imx ?

    What's the difference between uboot-fslc and uboot-imx? I'm trying to build an image based on yocto community-bsp. I see this one takes uboot-fslc per default. But I keep on getting -74 nand read errors with this ver...
    Wouter Vanhauwaert
    last modified by Wouter Vanhauwaert
  • Android :imx8mn display issue.

    I am trying to boot Android P9.0.0_2.3.4 on our setup which is imx8MN->MIPI->TI sn65dsi83 ->LVDS->Panel.   During the inital boot penguins logo comes up fine, however for boot animation I s...
    MOHIT SINGH
    last modified by MOHIT SINGH
  • UUU Issues with i.MX8MQ SBC

    I am attempting to use the UUU tool to access a custom i.MX8MQ board. I am running into a USB library error that I am struggling to solve.   Here is the simple sequence of UUU commands being attempted:  &#...
    Paul DeMetrotion
    last modified by Paul DeMetrotion
  • 2GB Micron DDR4 configuration for i.MX8M Nano

    Hello, We're trying to generate DDR configuration for our i.MX8M Nano board with 2GB Micron DDR4 DRAM. The DRAM datasheet is available at https://www.micron.com/products/dram/ddr4-sdram/part-catalog/mt40a1g16knr-075&...
    Ofer Austerlitz
    last modified by Ofer Austerlitz
  • too fast playback speed of video, recorded by gstreamer on i.mx6

    Hello. Is it possible to record framebuffer on imx.6 via gstreamer ? I've tried to use multifilesrc, but something went wrong.   For test I used command: while [ true ] ; echo `date` > /dev/tty0 ; slee...
    Eugene Kruglikov
    last modified by Eugene Kruglikov
  • Udoo Neo Full is loading imx6q-udoo-hdmi.dtb

    Hi Everyone! I'm newbie in linux system! After checking /sys/var/term.log, I saw linux OS of my udoo board, it load imx6q-udoo-hdmi.dtb and it dose not load any *.dtb file in /boot/dts folder. I tried to at this li...
    Anh Pham Tuan
    last modified by Anh Pham Tuan
  • i.MX6ULL gpmi-nand error during resume from suspend

    Hi. Booting from NAND flash (and using a UBI rootfs) and suspending to RAM (with the NAND flash power going down during suspend) - when waking up, we get the errors below* and the rootfs is switched to read-only mode...
    Ofer Austerlitz
    last modified by Ofer Austerlitz
  • firmware-imx build failure

    I have seen this for the past yer, but do not see a clear solution.    while running a build for poky and v3.14.79. it fails at:    ERROR: firmware-imx-1_5.4-r0 do_fetch: Fetcher failure: Fetch c...
    glenfine
    last modified by glenfine
  • iMX8M nano Processor Power Down

    Hi All,   I want to know more about the iMX8M nano processor, in this processor it has 4x A53-cortex(core0 , core1, core2, core3) and 1x M7-cortex would be there, my queries are as below 1) How to do the Power ...
    nandish sg
    last modified by nandish sg
  • Deletion of files in /usr/bin

    I am experiencing a strange behaviour in my Linux yocto image. Suddenly and no periodicity or frequency defined, after many months of operation, on a boot, binaries from /usr/bin folder has been deleted in one of my c...
    Pankaj Joshi
    last modified by Pankaj Joshi
  • iMX28 / FEC: ethernet link breaks on MAC reset

    I'm encountering issues with an iMX28 connected to a LAN8720 PHY chip on a board very similar in design to the MX28-EVK.    The symptom of the issue is the swinging ethernet link which has been discuss...
    Laurent Badel
    last modified by Laurent Badel
  • i.MX6Q Kernel Panic - Yocto

    I'm working with a BD Sabrelite board (rev-D), and attempting to boot a Yocto build: Linux version 4.14.98-2.0.0-ga+yocto+g040261770bd9 (oe-user@oe-host) (gcc version 9.2.0 (GCC)sor [412fc09a] revision 10 (ARMv7), cr...
    Joel Winarske
    last modified by Joel Winarske
  • MSI Still Broken on NXP BSP L4.14.98_2.3.1_patch?

    Since a while, we carry the pci=nomsi kernel boot command-line argument in our defaults. After our recent re-base on-top-of NXP BSP L4.14.98_2.3.1_patch we did some more PCIe tests but it looks like enabling MSI ...
    Marcel Ziswiler
    last modified by Marcel Ziswiler
  • i.MX8MM Freeze

    Hello, Our i.MX8MM board comes with 2GB DDR4 RAM. We have used DDR4 RPA tool V10 to create DRAM configuration. We are experiencing system freezes during boot when Linux busfreq driver (drivers/soc/imx/busfreq-imx8mq....
    Felix Radensky
    last modified by Felix Radensky