• repo sync error

    Hi,         I did "repo sync" o8.1.0.2.0.0.ga android source code, I got these error message repeatedly.         What can I do next? repo: warning: Python 2 is no longer...
    Kevin Li
    last modified by Kevin Li
  • imx8mevk board in Qt5

    hi. nxp   L4.9.88_2.0.0_image_MX8MQ file downlod in fsl-image-qt5-validation-imx-xwayland-imx8mqevk.sdcard file use weston wayland system ok! Qt5/examples test ok!     I want to run a my qt5 app ...
    an sunjib
    last modified by an sunjib
  • Bug-Fixes for FlexSPI

    We are using a SoM with an i.MX8M-Mini and tried to use the FlexSPI to communicate with an FPGA which simulates a flash memory using 1-1-4 or 1-4-4 transfer mode. To get that working we had to fix or extend the linux...
    Christoph Fink
    last modified by Christoph Fink
  • i.MX8QX QSPI FLASH ERROR

    Hi friends,   My board have mx66u51235f flash.   If I check at u-boot I detect like this: => sf probe SF: select 4B addr cmd set SF: Detected mx66u51235f with page size 256 Bytes, erase size 64 Ki...
    berat yildiz
    last modified by berat yildiz
  • Power Consumption ratings in i.MX8M Datasheet

    Hello, In paragraph 3.1.5 of the i.MX8M Nano Datasheet (IMX8NCEC) maximum supply currents of the device are mentioned. However, no information is given on which device(Single, Dual or Quad Core, Lite) these current...
    arnemaathuis
    last modified by arnemaathuis
  • Can't open device. No such a file/directory

    I am working on imx8mmevk. I have configured for ecspi2 "fsl-imx8mm.dtsi" as :   ecspi2: ecspi@30830000 { #address-cells = <1>; #size-cells = <0>; compatible = "fsl,imx8mm-ecspi", "fsl,imx51-ecspi...
    Rutuja Patil
    last modified by Rutuja Patil
  • imx8mq load fimware to m4 from linux

    Hi. I am trying to use the M4 core from linux in an IMX8MQ processor. I tried the m4fwloader but it says: "Board is not supported.". Then I tried m4ctrl, but after the "insmod m4ctrl_dev.ko" step, I ...
    Ioannis Gragopoulos
    last modified by Ioannis Gragopoulos
  • DDR stress test cause system hang in Linux

    Hello NXPs, Release: Yocto-Sumo (4.14.98_2.0.0_GA) Board: i.MX8MQ EVK based custom board We're working on iMX8MQ based custom-designed board with 2GB DDR4 RAM (MCIMX8M-EVK 3GB LPDDR4 RAM) now we're having an issue whe...
    John Coll
    last modified by John Coll
  • Gsteamer conflicting declaration in opencv

    Hello, I am building Yocto 2.5(Sumo) with Gstreamer 1.14 and OpenCV 3.4.5 I am getting this error while compiling Gstreamer: build_xwayland_mq/tmp/work/aarch64-mx8m-poky-linux/gstreamer1.0-plugins-bad/1.14.4.imx-r0/...
    llya Sonin
    last modified by llya Sonin
  • MJPEG encoded by ffmpeg 3.2 doesn't decode on iMX8MQ

    I have video content in MJPEG format which I try to decode. It has been encoded using ffmpeg 3.2. The hardware decoder gives an error saying the stream is not supported. If I split the content into seperate frames (in...
    Nico Coesel
    last modified by Nico Coesel
  • MIPI Display to IMX8 MQ

    Dear All, We have connected MIPI display to imx8 MQ, We are concern like panel information along with display-timing parameter shall be defined in in dts file. whether panel and display parameter shall be defined in ...
    kishore poojari
    last modified by kishore poojari
  • I.MX8QMax -- How to Compile QT Cpp code

    Hi, How to cross compile simple QT Cpp code for I.MX8QMax. I did below steps   export PATH=/opt/fsl-imx-x11/4.9.51-mx8-beta/sysroots/x86_64-pokysdk-linux/usr/bin/aarch64-poky-linux/:$PATH export CROSS_COMPIL...
    Santhosh Kumar
    last modified by Santhosh Kumar
  • SSH on I.Mx8mmini

     I want to access the board from network so How to enable SSH on I.Mx8mmini.
    Santhosh Kumar
    last modified by Santhosh Kumar
  • How to add OpenCV examples in imx-gpu-sdk recipe for i.MX8mq board?

    Hello,    I am trying to add OpenCV example applications present in the imx-gpu-sdk recipe source code but i am unable to build the OpenCV sample application codes?   Could you please show me how...
    Chandresh Tank
    last modified by Chandresh Tank
  • imx8mm u-boot update

    I am looking for detailed instructions on how to update the u-boot image for the iMX8MM EVK. The instructions in the "android frequently asked questions" has some info but lacks details to where to get the scripts and...
    suly goonetilleke
    last modified by suly goonetilleke
  • iMX8MQ EVK DisplayPort

    I am evaluating DisplayPort support on iMX8MQ ( with the DisplayPort EVK board ). I am using NXP release L4.14.98_2.0.0_ga_images_MX8MQEVK binaries. I update the boot image with imx-boot-imx8mqevk-sd.bin-flash_d...
    Stan Bertrand
    last modified by Stan Bertrand
  • Complete steps for AHAB secure boot imx8qm-mek

    I am looking for the complete set of steps for setting up secure AHAB boot on the imx8qm-mek board.   I can fully create U-Boot, kernel, DTB, and rootfs and boot without security. I have read the guide which is ...
    Stuart Rubin
    last modified by Stuart Rubin
  • What should I write for the "fsl, dataline" parameters?

    Hi community.   I'm developing a device driver for 48KHz / 32bit/ 16ch TDM Audio codec (capture only).    When I use RXD0 - RXD3, What should I write for the "fsl, dataline" parameters? I looked...
    Takashi Kashiwagi
    last modified by Takashi Kashiwagi
  • i.MX8M power consumption in deep-sleep mode without HDMI

    In table 2 of i.MX 8M Quad Power Consumption Measurement AN12118 <http://nxp.com/doc/an12118>, it has power consumption in deep-sleep mode with HDMI. Where can we find the power consumption in dee...
    m.c
    created by m.c
  • AOSP Update

    Hi, I am using iMX8M Mini EVK and AOSP 9.0 version and I am able to run AOSP successfully on my EVK board.   In my current AOSP version AOSP 9.0 I added some custom code in system service layer, JNI layer, HIDL...
    Maneesh Singh
    last modified by Maneesh Singh