• I.MX8QXP Android P auto camera HAL3

    Dears,   If I want to used enable /imx/libcamera3 camera HAL3 code in OS,and used Max9286 to connect camera, how to I change the source code? I think now get video devices flow not proper for MAX9286 chip,log ...
    Xu Ji
    last modified by Xu Ji
  • i.MX8QM ENET_REFCLK_125MHz source?

    I'm designing and RGMII interface  for a 1000BASE-T1 PHY and understand that ENET_RGMII_TXC is an output to provide a 125MHz signal to the PHY. On the i.MX6, this 125MHz clock could be provided externally or rout...
    Peter Bain
    last modified by Peter Bain
  • i.MX8QM dpu loopback to isi.

    On imx8qm there are two DPUs(display process unit) and one ISI(image subsystem interface), ISI has 5 inputs and two of them are from DPU0 and DPU1.   DPU, ISI block diagram: This document demonstrates on how ...
    Bert Xu
    last modified by Bert Xu
  • i.mx6dl usb device disconnect from computer

    Our new project now customer feedback an issue is that  usb device disconnect from computer sometimes but it can recover connect immediately. MCU module: MCIMX6U5EVM10AC Action: 1. USB eye diagram test is...
    zhongwei he
    last modified by zhongwei he
  • imx6ull burned image to nand by uuu

    Hello, I'm using the imx6ullevk board and L4.14.98_ga, and want to burn image to nand using uuu. I have change some parameters to ahieve uboot for nand & ubi rootfs. And as for imx6ullevk's "nand read", I set that...
    Ida J
    last modified by Ida J
  • How to display subtitles on iMX6 using gstreamer 1.0

    Hi there! I can’t display external subtitles on iMX6. I tried to use the next command - gst-launch-1.0 playbin flags=0x17 uri=file://$VIDEO_FILE suburi=file://$SUBTITLE_FILE.  Video plays fin...
    Osman Bosman
    last modified by Osman Bosman
  • How to extend a V4L2 control

    Hello, I work with a i.MX6Q and connected an quad video encoder chip over CSI-0 interface. The encoder chip streams the data via BT656 and has a I2C control bus. On software side I use the mxc_v4l2_capture.c drive a...
    Michael Stahl
    last modified by Michael Stahl
  • RTC1 cannot find in the /dev

    Hi, we added rtc1 function in the device tree of kernel. Our BSP is 4.14.78 and platform is i.mx6ul. But we can not find rtc1 in the /dev folder. What is problem ?   #include "imx6ul.dtsi"   / {   &...
    hank wang
    last modified by hank wang
  • imx6sl用mfgtool烧录的问题

    我手上有一个imx6sl的e-link阅读器,我想知道怎么设置成boot下载模式,然后使用mfgtool烧录
    永辉 谢
    last modified by 永辉 谢
  • imx6q for 7181c

    Hi all:        I am using ADV7181c on our board with iMX6Q. I have tried to modity the source code in adv7180.c . And the BSP I used is linux 3.14.52.        I modified t...
    sen li
    last modified by sen li
  • booting process for imx8qm along with Xen

    Hello,           i want to work on imx8qm mek board. I am building android, Along with that I want to implement Xen on this. I would like to know how the booting process takes place when xen ...
    Nakshatra A
    last modified by Nakshatra A
  • IMX6QP LPDDR2 Calibration Issue

      Hi All,   We need some help for iMX6QP LPDDR2 Dual-channel bringing up. Here are details below.   Board ID: SCH-29181 REV B DDR Device: Micron - EDBA164B2PR  Programming aids: MX...
    Kael Hong
    last modified by Kael Hong
  • tlv320aic3104 under linux version 4.14,imx8m

    Hello Team  Could anyone tell me is there a working driver for tlv320aic3104 under linux version 4.14 , based on imx8m? To make tlv320aic3104 works, what driver's components at least that I should port in? I j...
    yvonne chen
    last modified by yvonne chen
  • i.MX 6ULL 9x9 BGA footprint

    Hello! The i.MX 6ULL hardware development guide recommends using the footprint designed by NXP. It also states that the native allegro gerber files are available on nxp.com. I can't find these files. I can get the 14x...
    Amy Domino
    last modified by Amy Domino
  • Cable diagnostics for TJA1100 PHY

    We are working with the TJA1100 as a PHY with MPC5746C. As stated in the Datasheet and the application note for TJA1100 to run the cable diagnostics : -> The PHY must be in normal mode and then set the Cable tes...
    ahmed saber
    last modified by ahmed saber
  • iMX6ul evk board MPD (Music Player Daemon) + ncmpc

    I can't cross-compile MPD because of very much dependencies, it really must be compiled on the device it will be using, but it is impossible to install it on the board because board has no needed packages too and pack...
    Vladislav Redin
    last modified by Vladislav Redin
  • MCIMX6DLAICPU2 board will not boot with certain SD card

    Hi All,   I have started to work with the MCIMX6DLAICPU2 board and I have successfully build an sdcard image using the information found in the imx-yocto-L4.14.98_2.0.0_ga i.MX Yocto project user's guide. ...
    Olaf Heemskerk
    last modified by Olaf Heemskerk
  • How to recover MCIMX7SABRE board loaded with an abnormal image

    Hello, Community.       I'm trying to debug an application by loading an image to the QSPI flash on iMX7D via JTAG. The evaluation board used is MCIMX7SABRE.       One day,&...
    Yuichi Takeda
    last modified by Yuichi Takeda
  • MCIMX6X4CVM08AC v.s. MCIMX6X4AVM08AC

    Hi Sir: Our design has the system performance issue during high temperature, our BOSS would like to explore replacing the current part MCIMX6X4CVM08AC (industrial version -40C – 105C) with MCIMX6X4AVM08AC (...
    Samuel Hsieh
    last modified by Samuel Hsieh
  • bitbake can not fetch recipes-devtools

    Hi,NXP Expert      I try to set up the Yocto Project on a Linux machine and build an image. quick start $: mkdir imx-yocto-bsp $: cd imx-yocto-bsp $: repo init -u https://source.codeaurora.org/e...
    run zhao
    last modified by run zhao