• Autosar MCAL CW Compiler

    Dear Engineers. We are automotive electronic company. Our customers want Autosar and E2E (End to End). Because of this request we want to upgrade our microcontroller as MPC574xG. But our team leader want to compi...
    yunus karamavus
    last modified by yunus karamavus
  • Stack consumption in codewarrior

    I have enabled stack usage in linker in properties in codewarrior. I then added the ISRs and startup in entries section in .prm file.   In map file we could see the stack consumption but the entire project tree ...
    PRATIBHA SURABHI
    last modified by PRATIBHA SURABHI
  • CW connect DEVKIT-S12XE

    Hi Sir,   I got the error message when I try to debug code on the DEVKIT-S12XE.   Could you help to the issue ?   Edi.
    edison wu
    last modified by edison wu
  • Illegal constant expression: copying address to a variable

    I try to compile the below mentioned code in Code-warrior 10.7 but CW throws an error "illegal constant expression"   Code:   uint32_t val1; uint32_t val2; uint32_t val2 = (uint32_t)&val2;  &...
    Amit Dhand
    last modified by Amit Dhand
  • Target request fail : GDI protocol Adapter: stop failed,Non Fatal Error

    Sometimes we don't use external debugger but OpenSDA on-board . The debugger controller clock setting need more attention because of slow debug by OpenSDA on-board. if you set the bus clock too high to make step ...
    Junjie Lai
    last modified by Junjie Lai
  • SSI using K60 Processor Expert

    Hi , I have TWR-K60F120M Tower Module. I am trying to set up and use SSI_LDD from Processor Expert. The Receive Clock is set to pin PTE9. Code: LDD_TDeviceData *SSI_Device; SSI_Device= SSI1_Init(NULL); int16_t d...
    David XY Zhou
    last modified by David XY Zhou
  • what codewarrior tap for spc5200cbv400b

    My old code warrior tap (CWH-UTP-PPCD-HE) has failed.  What tap do I need to buy to support my processor (spc5200cbv400b).   Thanks, Glen
    Glen Larmore
    last modified by Glen Larmore
  • CodeWarrior Tap GDB server gives error when executing -data-evaluate-expression

    I'm connected to the GDB remote server on the code warrior tap to debug the QorIQ® P1021|NXP : I get the following error when running -data-evaluate-expression (uart)->rx_tx_dll   Failed to ex...
    Zachary Wilcox
    last modified by Zachary Wilcox
  • CW 10.6 linker issue

    Hi everyone, for a project with KL16 in CW 10.6 the linker does not work, it breaks with these errors:    ARM_GCC_Support/ewl/EWL_C/src/sys/uart_console_io.c undefined reference to `InitializeUART' &#...
    Daniele Colucci
    last modified by Daniele Colucci
  • math.h

    Hello everyone, Who has a general library of mathematical functions for Freescale mc9s08dz chips?, (math.h) Please provide one. Thank you. Thank you very much.
    jixiang li
    last modified by jixiang li
  • how to program T4240RDB flash connection based our custom board using codewarrior Flash programmer

    Hi everyone! In out custom board we are using two flash chips are connected with T4240 as shown in below attachment. we tried to flash it using amd16x2.elf (64Mx16x2) via flash programmer, It provides sector protect ...
    dhana sekaran
    last modified by dhana sekaran
  • The new Alamak car.

    Hello,   We are lebanese students, we are in TFC, we have the alamak kit.The documentation is very poor, please help us. Provide us with good and solid start documentation.   We tried a sample code for the...
    bashir abdelwahed
    last modified by bashir abdelwahed
  • CodeWarrior10.6.4:How to generate Binary File?

    Dear:   when I want to generate Binary File, The error message is as follows:   How can I fix this error?
    maoyuan luo
    last modified by maoyuan luo
  • about CW11''s optimsize difference for O1 and O3

    hi all    My client uses S9KEAZN64 with CW11,found that a operation for internal EEPROM,CW11 has 2 optimsize leve,one is O1 ,another is O3,my client found the function has some error,when use optimize ...
    Teddy Wang
    last modified by Teddy Wang
  • CW MCU - MC9S08QG - old DEMO9S08QG or new LFEBRS08DEMO

    Now I have downloaded CodeWarrior for MCU RS08/S08  v11.1 of my PC und need and want to buy target to program MCS08QG (only this type). In this moment only I know old DEMO9S08QGe. But of NXP-site I see new ...
    Gerd Meinert
    last modified by Gerd Meinert
  • simple question about .prm file

    Hello, every one I have a simple question about .prm file format   I simply understood .prm in codewarrior, which allocate memory map between source code and physical memory. so, I want to know more detail abo...
    gidong kim
    last modified by gidong kim
  • ccs protocol plugin::could not connect to the requested core core#0

    We are using the MPC 860 power pc QUICC processor we are using the code warrior IDE for debugging . While entering into the debug we are getting an error as below .Find the below attachment for the CCS log. Thank you...
    maheshwar reddy
    last modified by maheshwar reddy
  • Please help me.About the setting problem of CodeWarrior2.10.

    I don't know how to set CodeWarrior2.10 to output compilation information at compile time.Just like the following picture (CW_For_S12_v5.1). When I set CodeWarrior2.10, the compilation result is as shown below. I ...
    法龙 王
    last modified by 法龙 王
  • supported code warrior version for the MPC860 power pc with processor ?

    we are using MPC860 processor . we are unable to found the device itself in codewarrior 10.5.1. so which version of the code warrior IDE supported. Thank you Best regards
    srikanth ravada
    last modified by srikanth ravada
  • Problem while installing the codewarrior 8.8

    Now we are using the MPC860 power pc in our custom board. To dbug we are trying to use the code warrior 8.8 but while installing the code warrior we are getting an error as cannot not run an x86 built of this utility ...
    maheshwar reddy
    last modified by maheshwar reddy