• Expected BDM command ACK missing with USBDM 4.12 and JMxx firmware

    Hi to all the community.   I have an issue with the USBDM 4.12 and JMxx firmware. The resources i´m using are the following:   *- Board: (USBDM: USBDM RS08/HCS08/HCS12/Coldfire V1,2,3,4/D...) which u...
    martin mignone
    last modified by martin mignone
  • USBDM-JS16-SWD for programming MK60DN256VLL10?

    I got a board with a MK60DN256VLL10 Cortex-M4 chip aka K60P100M100SF2V2 (from the datasheet) and we have an USBDM-JS16-SWD lying around, a USB programmer labeled "freescale USBDM" from a previous projec...
    Alexander Dahl
    last modified by Alexander Dahl
  • Read 9s12xe384 via usbdm

    When I read memory, program gets only 44kB data. The area of Pflash is 348kB. What it is wrong in setting memory dump? Also. Is some possibllity read EEEprom, dflash (EPage register)?  
    Tom Sek
    last modified by Tom Sek
  • Unable to install USBDN Eclipse(Kepler)

    I installed USBDN for  selecting the Eclipse (Kepler) I didn't USBDN Menu.  So tried to install "Install New Software" in Eclipse   That gives me an error saying : Cannot complete the inst...
    Zachary Wilcox
    created by Zachary Wilcox
  • USBDM fails kinetis connection

    I get this error messages from USBDM when I trying to just detect chip ou execute the Mass Erase function on KV30 kinetis chip. Can someone help me? Is there a simple solution?      
    Daniel Alvarenga
    last modified by Daniel Alvarenga
  • What is the maximum frenqency of   OSBDM  ?

    Hello   In CW10.6, I can't debug the S12ZVMC12EVB if I change the Internal bus clock at 30MHz or 50MHz in the CPU software component. I use the following connection : "USB1:Embedded S12Z OSBDM/OSJTAG Device". Bu...
    fan xy
    last modified by fan xy
  • Can not install USBDM On Ubuntu 18.04.1 LTS

    Hey, Guy!    Can somebody help me? When I try to install the DEB Package, its say some depends are missing. So, i unzipped the deb file then i find a Document which call control, it shows the package n...
    Haoda Lei
    last modified by Haoda Lei
  • UsbdmFlashProgrammer command line

    Hi,   I have a problem with UsbdmFlashProgrammer command line. I use a HCS08 MC9S08PA32 Cpu and want to program it with the UsbdmFlashProgrammer tool. If the cpu was not programmed before (clean and fresh one)...
    Werner Dungs
    last modified by Werner Dungs
  • S12xet256 cannot mass erase

    New design, unprogrammed S12XET256 will not communicate with USBDM.  USBDM says chip is secure but will not mass erase to allow access.
    Robert Richardson
    last modified by Robert Richardson
  • Can Usbdm read data from S9s12G64 mcu?

    Can Usbdm read data from S9s12G64 mcu? If, how to connect pin config and which application software should I use? I bought usbdm last month. But there is no Cd for to install u sbdm software. Help me please.
    Saw Eddie
    last modified by Saw Eddie
  • USBDM Unable to program MC9S12G128

    Hi pgo I'm working with USBDM from Witztronics using WTUSBDM_CF_JM to program S9S12G128 but I have some issues for example when I tray to flash the memory program it says "Program data not within target flash memory"...
    Carlos Juarez
    last modified by Carlos Juarez
  • USBDM - Version 4.9.4 (JS16/JMxx Hardware Versions)

    Dear All,   USBDM has been updated to V4.9.4.   Please post any queries on this version in this thread,   Information available at: SourceForge   bye   Note Please note that t...
    last modified by pgo
  • USBDM can't  “Program Flash”

    Dear Support team, I use USBDM ,   The setup is USBDM_4_12_1_210_Win.msi When  I do the last step “Program Flash” ,the error attached happened。"programming Erase Mode" is choiced "EraseMass"....
    Virgo Zhou
    last modified by Virgo Zhou
  • USBDM HCS12_FlashProgrammer Problems

    Hi,   I've been trying to flash my Dragon 12+ board with the USBDM and have been running into some issues. I am trying to replace the D-Bug12 monitor with the serial monitor but am running into issue. I have fol...
    Austin Copeman
    last modified by Austin Copeman
  • Unable to program HCS12 device using USBDM / TBDML

    Hello everybody, I'm working with a HCS12 device, more specifically MM912j637 which can be used as a battery monitor. My environment includes Code warrior 5.1 for HCS12 devices, as well as the HIWAVE debugger. The b...
    Georgi Petrov
    last modified by Georgi Petrov
  • Helppp!Seek a 9S12XPE100 program to encrypt chip,and then can't read PartID.

    Seek a 9S12XEP100 program (.S19), when the program is burned into the 9S12XEP100, the chip will be encrypted and cannot read Part ID. Thank You !
    帅哥 谢
    last modified by 帅哥 谢
  • USBDM, FRDM-KL25Z, not detecting K60 or KE18F?

    I've been using USBDM ( ?) with a FRDM-KL25Z board to work on K60 projects successfully. Now I'm trying to bring up a KE18F board. The board and software that I was using didn't seem to detect the processo...
    John Adamson
    last modified by John Adamson
  • Page Programming issue for MC9S12XDT512

    Dear pgo,           I have trouble to reading Flash of MC99s12XDT512. And the flash programmer can program from 0x0000 to 0xFFFF.
    alan jiang
    last modified by alan jiang
  • Unable to connect to MC9S08AW60 with OSBDM JS-16-CWJ

    I've recently bought a new MC9S08AW60CFUE with minimal system, and a BDM using MC9S08JS16CWJ, but keep fail to connect them.   I've tried plug or unplut RESET pin, tick or untick "Use hardware RESET", manually c...
    Lidong Wang
    last modified by Lidong Wang
  • Unable to connect to MKE04Z8 with USBDM JS16-SWD

    Hi,   I have spent several hours with debugging this case without any success. I would ask for your help!   We made a hardware with an MKE04Z8VTG4 and we have build our own JS16-SWD programmer. Unfortunat...
    last modified by anewsee